[WoL Campaign, Moebius Factor] New achievement does not trigger properly

Achievement: Contract Saviors

“Complete ‘The Moebius Factor’ mission by training only SCVs, Medivacs, and Mercenaries on Normal difficulty.”

I completed this mission on Hard and fulfilled the requirements – never training a single unit from the barracks, factory, or starport – and the achievement did not trigger.

I then completed the mission again on Normal without training any unit or building any structure at all and it still did not trigger.

This may be caused by the game giving you four normal marines at the very start of the mission.


This bug also occurs when you have to save General Warfield.

Yes, this is happening for me too honestly! Tried it in all the possible ways (I’ve re-done this mission at least 7 times thinking I was crazy and did it after not training anything and the achievement is still not triggered).

They should not only fix bug for these two (or more) missions, but also add lines telling us if training (calling) MULEs is allowed for achievements or not

Just tried it on Gates of Hell (“Band of Brothers” achievement). You’re right, it doesn’t work there either. I even avoided rescuing any drop pods just in case that counted.

Same here. Tried 2 times, still doesnt pop up for me.

Moebius factor one is completely impossible because the game searches for ANY built unit that’s isn’t an scv/merc/medivac, including the ENEMY’S built units.

The one on gates of hell is possible, but I’m not exactly sure what breaks it. I got it by making literally nothing. I only got infantry upgrades on the provided engineering bay and rescued the drop pods. No mules, no spider mines, no structures (although I’m like 95% sure structures are ok, after testing moebius factor).

All achievements officially can be done.

No, isn’t fair, if the achievement says “do this thing to win” is that condition, not “do this but secretly need to do this”
I saw the videos and they do this

  1. need to rescue everybody
  2. dont create more than 4 evamed
  3. Destroy an egg near the 1st target
  4. do it all in LESS THAN 3:20.
    Sorry but not all people who play scII have the ability to do that, also as I said, the condition doesn`t said about time or specific objectives. so is bugged and doesnt need to be excused to do it. Plz blizzard fix it

I do agree that Blizzard should fix it. But I will say that I disagree with the fact that they HAVE to fix it and this whole idea of “unfairness”.

I think we are too used to the availability of patches that many people are just wanting to be spoon fed. In the past when games were on CDs, patches DO NOT EXIST. This also means that gamers don’t have the luxury of “you messed up this part, please fix it”. Instead, they needed to find out how to workaround the bug in order to achieve what they want. This, to me, is the true essence of what gaming is.

Know that when it comes to gaming, not everyone is able to get everything in the game as well. The whole idea that “we should make things more available to all” is the reason why WoW is in the current state right now. Gone are the days when you look at a Legendary weapon and you go “wow, this guy has this”. Instead, everyone feels that “it’s alright, we will eventually get it”. It removes the uniqueness of having something special.

I didn’t even realise it until I began working with the others on the forums on how to get around the limitations. We needed to research and explore what are the programmed triggers and theory craft. This is the real gaming… in case you didn’t know.