Templar's Charge- Expert Phase-Smith, Perfect Templar

Are you sure this achievement is not bugged? I tried doing it with mass Carriers thrice and with mass Void Rays once. I was careful not to get any unit, structure or anything killed, especially at mass Void Rays try (I even sent Carriers to the lower left edge of the map, just in case).

1 Like

Tried the achievement with mass carriers, mass voids, no using solar lance or purifier beam or deploy fenix. I was quite sure not having lost any probe, carrier, ecc… but still no achievement.
It’s still buggy!

It is. If you use Solar Lance or Purifier Beam or Deploy Fenix, it will count behind the scenes as a unit dying and fail the achievement.

Same. I did attempted it with void rays + mirages, with Chrono Surge, Orbital Strike, Shield Overcharge and Time Stop as my actives.

And I didn’t even use Orbital Strike, just to be safe. Also kept exact count of my probes. Didn’t loose any structures either.
-> Still no achievement.

Aside: is it possible to record replays of single player missions? That would make keeping track of stray lost units so much easier.

Finally got it, this time I used Carriers and avoided the “floating” mineral pickups and the bonus objectives.

Bonus objectives bug was supposedly patched, so seems like the pickups are the issue

Indeed, seems that Solar Lance was actually the issue in my case. Thanks.

I used carriers, avoided the floating minerals, avoided the bonus achievements, used deploy pylon, temporal field, orbital assimilator, shield overcharge, guardian shell, time stop, lost no probes, but still did not get this achievement. Not sure what is going on, but it sure is annoying!

I got really tired of this achievement. It’s really annoying.

Finally achieved! I used the following Spear of Adun abilities: Deploy Pylon, Temporal Field, Orbital Assimilator, Shield Overcharge, Reconstruction Beam, and Time Stop. I built only Void Rays-Focused Siege. I moved the 3 initial carriers to lower part of screen so they would not be attacked . I did not pick up any “floating” minerals, nor did I go after bonus objectives. I built a Forge and upgraded to plasma shields level 3. I upgraded air armor and air weapons to level 3 as I had the minerals and vespene. I used Khaydarin Monoliths for defense and made sure I had plenty of shield batteries. I saved frequently as I moved along and advanced carefully. I am not sure what triggers the failure, but this worked for me.

Hey all,

If you still haven’t have gotten this, try this test map out:


[just quoting to ping you all]

carriers doesnt work , pretty sure , but mass voidrays no topbar abilities works , 12 is enough

Carriers were patched and can definitely be used. I made the achievement many times during all my testing.

The SoA abilities can be used except Solar Lance, Deploy Fenix and Purifier Beam.

1 Like

Thanks Leviathan! I read your other post, and I didn’t know that cancelling a structure would make the achievement fail. I re-tried, building only on the platform, not cancelling, mass carriers, taking all the floating minerals, using only deploying pylon and mass recall of SoA…and succeeded!! :slight_smile:

achievement still bugged; tried everything mentionned 4 times; doesn’t work

Have you tried loading up the test map I made to help figure what is causing the achievement to fail?

After they patched the Interceptors, the only thing left that can unexpectedly fail the achivement is the use of the three specific SoA abilities. Lots of players have been able to get it (many times myself in my testing) so even though there is still a bug with the SoA abilities, it is fairly simple to do.

The test map will tell you both when you failed the achievement and what caused it.

ok thanks; it worked, apparently i got a building destroyed

It seems as though the bonus objective is also causing issues. Likely the solarite being collected counts as units lost. That or the achievement is unreliable in triggering, since that’s the only thing I did differently

The bonus objective definitely doesn’t play a roll. If it was, my test map (linked above) would indicate that, but the over the many, many times I’ve tested it, the bonus has never caused the achievement to fail.

From what people are reporting back, they cancelled a building that was in the warping process. That counts as losing a structure.

I didn’t cancel or lose any buildings, and i kept track of my worker count to make sure I didn’t lose anything there. I ran the mission at least 3 other times, and the one time I didn’t do the bonus it worked. So at this point i’m stumped

I did the mission step by step with void rays, as well making sure I lost no buildings or units as well didn’t use any of the ability’s and still did not get the achievement. does anyone have updates on this issue. Have I missed something completely?
EDIT: I reset SC2 and I checked my achievements and it gave it to me i also didn’t cancel the final cut scene so i don’t know if that helped.