Stuck in authentication loop

When I open the game I just instantly get the authentication screen, and it automatically logs me into an account. If I press cancel, or log out of said account, I still don’t get the log in page, the authentication screen just comes back, and it is stuck in a loop.

I’ve tried restarting computer/game/ and nothing changed.

Hey, Torlock! This sounds like an odd behavior with the StarCraft II client. I tried to see if the same issue would happen on my end and it seems to be fine. My guess is that when it’s canceled or logged out it’s having connectivity issues to the login screen or a file might be corrupted causing the authentication loops.

Have you tried uninstalling the Blizzard Application and/or the game then reinstalling? Does the same loop happen on an alternative connection or VPN to test?

I’d like to see exactly where it gets stuck, if you could grab a screenshot of what’s the authentication loop looks like. Use an image sharing website like imgur and paste the URL between two ` (~ key) like so:

`Link Here`


I have not tried uninstalling the game yet. I was hoping to find a solution that didn’t require uninstalling due to bandwidth limits, but it wouldn’t be the end of the world if I had to.

A VPN doesn’t change the problem, and a different computer on the same network doesn’t have the problem.

I also tried uninstalling the launcher and deleting the cache which had no effect. As well as launching the game directly from the folder bypassing the launcher, and that also had no effect.

It’s worth noting, upon opening the game for the first time the game automatically logs me into my main account (let call it account A). Account A is the account logged into the Blizzard app. However if I log out of that account I immediately get the authentication screen, and I get logged into a different account (account B) with no way of entering a different email/password.

So when I open StarCraft, I get the authentication screen, and I get logged into account A. If I press cancel, or if I log out of account A, I get the authentication screen but I am then logged into account B.

Here is what it looks like

Pressing the cancel button makes the authentication popup briefly disappear and then reappear. The username and password box never appear, when the popup disappears that area is just blank until the authentication popup appear again.

I tried to make all this coherent, but I feel like it’s still a bit of a jumble of information, so let me know if you need anything clarified.

Not sure if it matters but I’m running Catalina 10.15.5 on a 2016 MacBook pro.



Soulds like you may be running into a caching issue. What happens if you clear your application cache? If you have any third party security, that may also be worth temporarily uninstalling.

Hi, I tried that and the problem is still there. I also tried uninstalling and reinstalling the launcher, and I tried launching the game from the applications folder directly, so that the app wasn’t involved at all. None of those fixed the problem.

Hey, Torlock! Thank you for the details and giving those a try! I think its safe to say that connection doesn’t seem to be the issue here. It looks like something might not be cooperating with the login page properly. Could you try a New Admin account and see if the same problem happens there?

If that doesn’t work and with all that you’ve tried so far, we’ll want to dig into the system a bit further and see what’s going on here. Could you contact our technical support team with the system reports files? Please do not post the system report files on the forums.