Starcraft 2 wont start on my mac

I start up Starcraft and after a few seconds a pop up appears and says “SC2 quit unexpectedly” I tried re-downloading the game and my computer should have all the right specs to play. here is the launch data.
Help please

Hey,

There was a known issue with this earlier this year. Renaming the computer should fix the issue.

  1. On Mac Apple menu, go to System Preferences/Sharing
  2. Change Computer Name to something different.
  3. Click on Edit and then Okay.
  4. Close Preferences window.
  5. Test game again.
1 Like

Thank you for your response, but thats a pretty radical way to fix a problem. Isn’t there another way to fix it without requiring one to rename their computer?

Howdy! The process of renaming the system is straight forward and is the fix, you can rename it back afterward. This workaround seems to update the Preferences overall which is why it helps.

Thanks!

Thank you, that certainly is less intrusive. However, that does not work for those such as myself where their mac belongs to an active directory domain and has a policy that disallows one from renaming the computer name. How would one go about fixing the issue in that scenario?

This fix worked for me just now! Good luck!

[Edited by Blizzard] This thread has been inactive for some time. Please be mindful of resurrecting older threads. A new or more recent thread can be created to continue the discussion. Locking this thread.