StarCraft 2 system hangs on M1 Apple Silicon Macs

Hello everyone,

Development is currently aware of issues with StarCraft 2 causing a system hang on launch when vertical sync is disabled for M1 Apple Silicon Macs. For the time being, you will need to enable Vsync in-game or through the variables file.

You will find the variables in the following location:

~/Library/Application Support/Blizzard/StarCraft II

Look for the following line and enable the value to true.
vsync=false
Change false to true and save the file.

If the line is not there you can add the line to the bottom of the text file manually and save the file. Thank you for your patience while this is worked on.

7 Likes