Starcraft 2 not working after last update

“Starcraft 2 encountered an Unexpected fatal error”

Has been working fine for years, after last update it crashes after black screen few seconds then returns to desktop. Running mbp 2018 on Big Sur Radeon graphics, no virus/firewall.

1 Like

Hey there,

Was there a specific error code or crash id with this?

What, if any, troubleshooting have you tried so far to resolve it?

reply back with that and any other details you think might be important and that will allow us and the community to dig into this further with you.

Error only says “An unexpected fatal error occurred” no error code or identifier and no crash report in console.

I’ve tried:

  • Scan/Repair
  • reinstalled game
  • removed folder
  • deleted virus software
  • changed computers name in “sharing”
  • launched game from new user

mac OS Big Sur. v 11.5.2
MacBook Pro (15-inch 2018)
Processor: 2,2 GHz 6-core intle core i7
Memory: 16gb 2400 MHz DDR4
Graphics: Radeon Pro 555x 4 GB

Sobbing into the void here…

You have to move(?) sc2 into another account on your PC. I.E make a new account for SC2 specifically… I can’t exactly remember all the steps I used to get it working again.

Tried making a new account and fresh installed sc2 there, no luck. Also I’m on a mac

Same issue - unexpected fatal error a few mins into every game since Monterey update.

Running 27inch iMac
3.6ghz i9 10 core
AMD Radeon Pro 5700 XT 16 GB

This machine should be able to launch a shuttle but somehow cannot run SC2

1 Like

Did you name the new account SC2

I think there’s some weird bug where SC2 is unable to locate it’s own folders unless you’re playing it on a user that you named SC2.

Also make sure that when you right click SC2 game app and then press get info, make sure your accounts permissions are “read and write”