SC2 is lagging after Monterey upgrade

In the past I’ve run SC2 on low graphics on my 2015 MacBook Pro w/ integrated GPU with no trouble at all. After the Monterey upgrade, SC2 is lagging pretty noticeably. Anyone else experiencing this?

hmmm I haven’t upgraded to Monterey yet so I can’t really say but I hope others will chime in to help as I am also curious

Same, it’s pretty much unplayable for me on my 2015 MacBook Pro w/ integrated GPU. If this game is a big part of your life I’d hold off on upgrading to Monterey on those machines.

I did however just get a new MacBook Pro w/ M1 Max and it laughs at this game running on all the highest settings. I was able to play while charging from a 67W monitor cable which is just insane. Definitely don’t buy this laptop just to play SC but if you going to anyway for work then you’ll have no worries.

1 Like

Just curious. What is insane about playin the game while charging?

I have the MBP m1max 32 gpu/ram and it was running ultra settings no problem at 70fps a day ago now it’s lagging doing 15fps on an adjusted high settings. I’m confused at how it was running incredibly smooth highest settings past two days since I got it now today just running like trash

1 Like

The MacBook Pro 14-inch M1 Max comes with a 96W charger but I chose to use a single USB-C cable (video and power) from my monitor for a cleaner one cable setup which supplies 67W. So the fact that my laptop charges on that lower wattage cable while playing SC2 maxed out means my laptop isn’t trying too hard.

1 Like

Oooh wow. That’s awesome! I am looking forward to getting a new M1 max/pro some day or perhaps by then it will be an M2, who knows (don’t have the funds right now)

So in essence, I should NOT upgrade to Monterey with my intel MacBook Pro 15 inch 2017 if I want to continue playing SC2?

1 Like

Yep, do not upgrade your OS if you want to play SC2. It’s unplayable. Shame.


): very sad to hear. Any idea why this may be happening and also if it occurs for you on any of your other games?

Okay I think I may of had a breakthrough. I noticed all of my replays were missing and when I tried the “show replays in finder” from the game, nothing would happen. I went looking and tried to dig through my SC2 profile folder in the finder /username/Library/Application Support/Blizzard/Starcraft II/Accounts/account/profile, and it said I didn’t have permissions (in my own profile folder)? I did a Get Info on the folder and changed it so that my name had Read & Write permissions. After that, the game seems to be running faster. Try it and see if that helps you.

very interesting! I hope others can try this and see if it helps!

CaptMaule, would you say the game runs just as well as it used to or perhaps even better?

What resolution did you play on ultra settings?

I have an MBP M1 Max 32/64 RAM and I’m currently trying to find the optimal settings for the game. It turned out that it is very difficult.

High FPS at normal resolutions (2560p and above) can only be obtained by setting Shader to medium. If it’s higher, then the game slows down a lot and you can’t see any differences in the graphics - apparently M1/Metal is not able to work with non-optimized shaders. If the gameplay graphically itself is not much different from Medium to High and Ultra, then in the game cinematics of the campaign, Medium shaders look terrible…

It solved by playing Windowed (Full screen) in my case