SC2 Crashes at Launch on Catalina 10.15.4 --tried other solutions


When I try to launch SC2, it crashes and I get the error:
An unexpected fatal error occurred.

I have a 2019 MBP so I’m not sure what the issue is. SC2 ran fine until I ran into this issue a few weeks ago–I can’t remember if there were any Blizzard, SC2, or Mac OS X updates that coincided with it starting to crash. I usually get mainline updates quickly. SCR works fine.

Here’s what I’ve tried already:

  • Deleting and redownloading SC2
  • Turning off firewall
  • Changing computer name
  • Checking that it is running 64 bit (no option appears in Game Settings in the Blizzard app, and I read that this means it is 64 bit).
  • Reset In-Game Options on Blizzard app
  • Blizzard Scan and Repair

Here is my system information:
MacBook Pro (13-inch, 2019, Two Thunderbolt 3 ports)
1.4 GHz Quad-Core Intel Core i5
16 GB 2133 MHz LPDDR3
Macintosh HD
Intel Iris Plus Graphics 645 1536 MB

Please let me know if there is more information I can provide or other things I can try. I’d also love to hear if anyone else is running into the same problem.


Hey, Sisyphus! Thank you for the details provided here! The crash isn’t pointing to an exact cause, other than possibly some issues related to permission and notifications. Have you tried to test if the same problem happens on a New Admin account?

The problem looks a bit complex that we’ll want to work with you on this issue. If the problem continues on the new admin account, could you contact our Technical Support team directly to look into this issue?

Hello Caterpepi,

Thanks for your reply. I just tried launching SC2 on a new Admin account, and it still crashes on launch with the same error. I’ll contact the Technical Support team and post back if we figure it out.

Thanks for reaching out to our team, Swarmgirl! I’m seeing the ticket submitted. Hopefully, our team will get back to you soon and help determine the cause for the crashing issue :slight_smile:

Had the same problem – battlenet not starting after login since 10.15.4 upgrade – I managed to get it to work by changing the resolution of my MacBook screen.

Hey, MuttyBay! If that works, does it help to set it back to the normal resolution and use “Open in Low Resolution?”

  1. Quit the app.
  2. Open the Applications folder.
  3. Click the app once to select it, then choose Get Info from the File menu.
  4. From the Get Info window that opens, select the checkbox labeled ”Open in Low Resolution.”
  5. Close the Get Info window and open the app again.