Not Available While Initializing Game Mode

This is a known issue and I have been struggling with it since I tried to start playing sc2 again in the past few days. When I go into game nothing loads or connects and options to queue for games are grayed out. Match history and other parts of the profile don’t load either. Only campaign is playable. There is a Blizz support article on the issue here as this has been a known issue for years: https://us.battle.net/support/en/article/33690
I have tried all of the troubleshooting from this article plus allowing sc2 through all firewalls, disabling security, disabling firewalls, running battle net and sc2 as admin on my admin account, scan and repair, and reinstalling. Does anyone have any idea how I can fix this? Very frustrating to only be able to play campaign. Thanks

Hey, Raz! This is fairly generic error caused by connectivity issues. What’s the router/modem models in the household? Does the same problem occur on an alternative connection or VPN?

Could you provide a WinMTR test? Run this while in-game until the problem occurs for 10 to 15 minutes. Copy and paste the text file created and paste it between two ~~~ like so:

~~~
WinMTR Here
~~~

If you have issues pasting here, use Pastebin and post the end of the link. (ie. 123456 for pastebin.com/123456)

I have an xfinity router/modem combo that I put into bridge mode so I can use my netgear router. The game loads everything fine when I link to my phone’s hotspot so it is for sure a net issue for me. I connected to a VPN (canadian) through NordVPN. I left the game sitting in the menu for a couple hours and now it works fine. Unsure if the VPN made it work or the sitting and letting it be for a few hours. Will try to replicate and get back to you as well as with a WinMTR test. Thanks for your help

I was a bit concerned that this might’ve been a netgear router. We’re aware of some issues with netgear routers causing connectivity related issues.

By chance, do you still experience the issue when using only the combo xfinity router?

I tried some more things out. The problem still persisted with using only the xfinity router/modem combo. However using the VPN still seems to be making everything work. I am using the netgear router again now with the VPN and everything is fine. I appreciate your help. I do hope this has solved my problem. Of course this means there is probably still an issue with my net, but using the VPN is a nice workaround.

Glad to hear it workaround the issue! It does suggest that there’s issues with the network connection or with the connection route since the VPN is working. I’d be happy to take a look at the WinMTR test to see if we can provide you with any more information on the issue :smiley: