No mouse scrolling (panning)

I play SC2 on my MacBook. Since today my mouse does not move the section of the screen in the game anymore. I can click on objects and the cursor is moving, but when I go to the border of the screen the section won’t move at all. Any idea how to fix that issue? I am using a bluetooth mouse, but the Mac’s trackpad does not work either.

I have the same issue. In addition, it took really long to start SC. Something like 5 minutes. At first I thought it would not start at all. My macbook is on Mac OS Catalina version 10.15.5 (19F101)

I have the same problem with my iMac still using Mojave without upgrade to Catalina. Mouse cannot scroll in any direction

I specifically posted this here because usually most of my problems with SCII are Mac related. My post earlier today here was taken down. All I’m asking is why camera panning is so unresponsive in windowed mode.

I have the same issue. No panning at all. Also can’t move the cursor when building

It’s happened to me once. I got out of it by pressing Command-M to put it in windowed mode and then back again. I have bigger crashing issues (replied to in another thread) with the latest update too. Fun…

Thank you for your reports! There have been some known issues with MacOS and StarCraft II in particular. The mouse scrolling issues can usually be fixed by CMD + TAB out then back in or by forcing windowed mode CMD + M.

Could you provide us with the system information? Click on the Apple Menu and then “About this mac.” Please include the mac model, processor, memory, and graphics.

As technical support, we help with gathering information on occasion, but we are not the developers. We assist with technical issues that can be resolved through troubleshooting and present workarounds if available. For issues that appear to be a bug and needs attention from folks who can make the necessary changes, the #bug-report forums is recommended since the appropriate team will monitor the bug report forums :slight_smile:

We’ll continue to gather and track your reports here, and if we have any new information on the situation, we’ll do our best to keep everyone updated on the matter. Thanks again, everyone!

MacBook Pro (13-inch, 2017, Two Thunderbolt 3 ports)
2,3 GHz Dual-Core Intel Core i5
Intel Iris Plus Graphics 640 1536 MB

I previously had this issue a few weeks ago, combined with building placement not displaying, so had to guess on building placement (the building ghost would appear fixed and not move with my cursor, but I could place the building by clicking in the usual way). These issues did however go away after a day or two.

As of today the issue is back, and I have also noticed that when I drag select a group of units I do not see a box.

These limitations make playing the game competitively on the ladder very difficult.

MacBook Pro (13-inch, 2017, Two Thunderbolt 3 ports)
2.3 GHz Dual-Core Intel Core i5
8 GB 2133 MHz LPDDR3
Intel Iris Plus Graphics 640 1536 MB
macOS Catalina version 10.15.5

yes today it is happened and after exit game I can’t launch it again

Just updated to patch v 5.0.0.80949 and it killed mouse panning and basic operations like placing buildings. Will try to force the window focus.

Did it happen to you after an OS update? Heres an easy fix for this issue :

Go to system preferences
Security and privacy

check accessibility SC2 will have it disabled after the OS X update. Allow it and everything will work just fine