Launch impossible

For two days, when I try to launch the game, it cannot start. I only see the gray download window (with green scrolling).
I saw on the French support forum that I am not the only one.

1 Like

Hello
I also encounter the same problem, when I launch my game a loading window starts and never ends (during this time my games do not launch). I have already tried to delete and then reinstall the games but that does not change nothing, I was also advised to disable my antivirus to launch the games but nothing changes too.
I am not the only one to have a problem a forum in France speaks about it too. I hope this bug will have more visibility in order to be corrected
Thank you

There’s a possible work around that has worked for many players.

  1. Log out of the launcher
  2. On the sign in window, click the gear icon and select “Continue without logging in”
  3. Navigate to SC2 and launch it
  4. Log in when the login screen appears
  5. Once you’re in, you can log back into the launcher.
1 Like

This is not a fix. Everyone here has been disconnecting and reconnecting their client for months on end. Is there ANY attempt at all of determining what has happened?

Correct, it is not a fix, it’s a workaround. It will need to be done each time the game is launched (assuming the scrolling green bar is appearing when trying to launch normally).

Bonjour

j’ai le même problème
j’ai essayer la solution de Léviathan mais ça ne fonctionne pas non plus
toujours ce chargement infini

is there any attempt yo to find out what has happened or any explanation at all of the situation? this has been going on for months to hundreds of complaints and zero action

I also encounter same problem, since last Monday, I haven’t launch the game successfully. but today, after wasting too long time to launch this game, I load this game successfully, but the game gets stuck long time at any menu action.

Unfortunately, I haven’t heard anything since the initial acknowledgement where Bliz was gathering data as part of an investigation.

Hello Blizzard,

I was playing SC2 and my game suddenly hang up on me and and gave me an message saying surrender immidealy you will need to reconnect the services. This happened to me 2 times this week.Thx.

Walter Chow