Into the Void anniversary achievement

Been playing SC2 campaigns for those new anniversary achievements.

Just played Into the Void mission, where the achievement titled “Disintegration Doctrine” tells to “destroy all enemy structures and complete the primary objective” within 28 minutes. Well I did clean out the whole map and finished at 25:30 but did not get the achievement!

I remember there being some flying units at the edges of the map. I wonder if here’s a similar problem as with the new achievement for Forbidden Weapon: the achievement tells to destroy buildings, but in fact you need to kill all enemy units too… Here as well or otherwise bugged?

EDIT: to be certain I went and used cheat to see the whole map. There were 2 groups of flying enemies at the top corners, and NO structures whatsoever. I loaded my save (should enable achievements again after cheat use), went and killed the 2 groups before finishing the mission. Still NO achievement, even though the entire map was cleaned of enemy buildings & units!

EDIT2: finally got it, not sure what happened the first time since I cleared the map that time too.

I too am having the same not-unlocking issue with the achievements of Moebius Factor and The Infinite Cycle missions, problems so many others here have been reporting. For me the Salvation achievement did work though (my passive Spear abilities were Orbital Assimilator & Guardian Shield).

While I do LOVE it that Blizzard released new achievements for the campaigns (only thing better would be actual new campaigns, I’d love to have Nova-style shorter campaigns for Alarak & Stukov!), still these have somewhat rushed feeling to them. Not only these bugs and multiple typos in achievement descriptions, but also the achievements seem REALLY oddly balanced: some are so ridiculously EASY that I usually do the required thing while casually playing campaigns on brutal, and then some are so TOUGH that now I’ve been having struggle even when playing on normal, even though we we’re told they should be obtainable even on brutal. For some of the achivements I find it hard to imagine anyone capable of doing them on brutal (well, unless you’re dedicated speedrunner or world champion class competitive professional, but that’s just the thing: the glaring difficulty imbalance between achievements).

1 Like

Bro, same bug here. I also got bug for achievement of Gates of Hell mission. You CAN’T train any unit, just use initial forces, SCVs and the ones falling from above. I have done this for brutal, not a problem at all, but it is a mistake in either text or achievement trigger.

1 Like
1 Like

I did get the Gates of Hell achievement while having called down MULEs.

1 Like


I failed to get the achievement a half-dozen times (Loading in the last 2-3 minutes) despite having cleared the entire map of enemies (save for the ones Narud spawns). Each time I made sure to kill every enemy and Void rift before killing Narud. No luck.

Then I killed the void rifts, ignored the enemies and killed Narud, it worked. It gave the achievement moments after Narud died (before the cutscene, before the stats screen).

I did the Into The Void mission multiple times and cleared the map before 28 minutes and didn’t get it (finishing around 24-25 minutes). I was massing void rays.

Then I tried it once more, but using mass carriers instead, and I got it (finishing around 25 minutes).

I don’t think it’s related to whether or not I made void rays or carriers, and I’ve no idea what else it might have been.

At first, I didn’t get this achievement when destroying every building before 28 minutes. Turns out that right when Narud’s health gets down to low low red, two more buildings spawn right in front of him, but it takes a couple of seconds. If you are pummeling Narud then you will kill him before you even realize there are more buildings spawning.

I suggest waiting back just out of range of Narud until the NPC allies bring his health down slowly, then snipe the buildings as they spawn before Narud gets finished off.