Installing SC2 fails, but can install other games


I tried updating SC2, which resulted in " We couldn’t access a folder. This is usually because you’re not logged in as an administrator." error.

I uninstalled the game, reinstalled and when trying to reinstall SC2, I still get the “We couldn’t access a folder.” error. Interesting thing is that installing other games works w/o issue e.g Heartstone and SC1.

I tried other things from the support page as well:

  • running as administrator (does not seem to make a difference)
  • scanned the drive (was ok)
  • deleted the tools folder
  • restarted between reinstalls
  • changing the region did not seem to affect anything
  • not sure if it was wise, but one more thing I tried was uninstalling, deleting all stuff in regedit that matched “starcraft” and reinstalled, did not help.
  • tried to install outside of Program Files (did not help)

Other info:
I don’t use onedrive (disabling it did help someone else in the forum)
Disabled Windows defender (did not help)
Did not try to create another account yet.

Sometimes instead of the error the install popup just hanged and does nothing.

Is there anything else I could try?


same issue, another thread here Can not install sc2 - #3 by Valleria-21698

Same here. May be I can add one more thing. When I launch the app it’s start fetching other games at random, reclaiming disk space and so on. Could be related, but this is definitely a bug.
This is my error:


1 Like

Same issue, same error " We couldn’t access a folder. This is usually because you’re not logged in as an administrator. "

It starded when i tried to Update the game today. I tried fixing it by repairing the game (which did not find anything), and all my other games could update, but not SC2. I even went as far as to uninstall and reinstall the bnet app and still could not update. Right now, i went as far as to uninstall SC2 and i am currently trying to reinstall it but guess what ???

The bnet app stays on “calculating size” and does not move on with the install at all.

1 Like

I have the same issue. try to update the game and it gets stuck telling me to try again as an administrator. Tried that and the other troubleshooting in the error message link but nothing worked.


+1 same issue. FYI this is also happening to WOW: Cannot update WoW TBC - don't have administrator rights - Desktop App Tech Support - Blizzard Forums

For anyone with administrator error message:

Boot windows in safe mode.
Delete sc2 folder in Documents
Update or reinstall sc2.


Found a lazier way to get this to work - just rename the folder (“Starcraft II - old” or something), then restart and try the update. It worked for me first try.


It worked, thanks, i am re-installing the game without issues

1 Like

Works! In my case even without rebooting to safe mode.

Thanks for the help, @Plecto! Indeed, there was something messed up with permissions in the Documents/Starcraft II folder. I was not able to even delete it without editing its permissions first. Not sure if Windows or was to blame. Maybe deletion was even not necessary, but just fixing the permissions would have helped. Who knows.

It would be nice if the error message specified the folder it is having issues with in future or mention this fix in their support page for this specific error.

Helped to me as well. Pitty, I uninstalled game, so had to install it back and mess with configs again :frowning:

This solution dont work on mac os, same problem, windows solution dont help at all

I had the same issue, tried the same steps as you, and the solution in this thread with no luck. Turning off Windows Security Controlled Folder Access allowed me to install the game. Turning CFA back on with exceptions still blocked the install. The Documents folder is one of the default CFA folders on my WIn10 system, which contains a Starcraft II folder.

Hope this helps someone.

This is only a solution if you don’t mind losing all your custom map progress which is unacceptable.

I did not have to delete the “My Documents\StarCraft II” folder.
I just renamed it and was asked for admin privileges.
Once I renamed it, the Installation worked without issue.
Now, I should be able to restore those replay files back :slight_smile:


There is not need to delete the folder, just change the security permissions to your windows user and thats it.

1 Like

I fixed this by editing the security permissions on the “My Documents\StarCraft II” folder. I changed the ownership to the administrators group. Then I granted full permissions to the administrators group.


You don’t need delete doc folders, change ownership and add all permission to you user - ownership or group for you user

1 Like

This did it, changed administrators group to full control.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.