Flawless Victory Achievement Bug?

I have been achievement hunting during quarantine, both before and after the most recent patch, and I think I’m hitting a glitch with the Rak’Shir mastery achievement. I have completed the Flawless Victory requirements multiple times on Hard and once on Brutal and I still haven’t received completion credit. Other achievements have registered, so it shouldn’t be an issue with server connections or anything like that.

In one play-through, I even walled off Alarak on all three possible attack paths so he couldn’t possibly be pushed back until I was ready, only activating his forward push once I had an unstoppable Voidray army and most of the enemy Nexuses were dead.

Has anyone else experienced this recently? I watched old YouTube videos of people beating it from much closer to LOTV’s release and in some cases our approaches (and results) were very similar but they got the achievement and I haven’t. Is it possible something in the 5.0.0 patch, with the adding of new achievements, screwed up the old achievement’s activation trigger?

1 Like

Possible actually. Because the Kerrigan coop achievement has been affected.

So I waited for the new patch and then tried it again (today, as it happens). Still no trigger. I fear this issue will get lost in the noise since all the focus has been on fixing bugs directly related to the 10th anniversary achievements.

So I gave it one more try going for speed over consistancy and this time I was able to beat it on Hard in 10:52 and got the achievement.

I am now 100% convinced that Flawless Victory has inherited the under 12 minute requirement from Timing Push.

From the map editor:

  • The achievement is gotten if winning the map in hard or brutal, with Alarak having never been pushed
  • Alarak is considered having been pushed if “the amount of enemy units near the tug of war” is above 0 while “amount of friendly units near tug of war” is 0.
  • “the amount of enemy units near the tug of war” is decided by picking units in an area that are enemy to the player, that aren’t Ma’lash, that aren’t a Protoss observer, and have something called “Pit Malash Shield Regen”.
  • The “Flawless victory” achievement is granted during the event triggered by Malash entering an area near his pit of death, the anniversary achievement is granted in the final victory sequence (after cutscenes).

Can’t see how the 12 minutes would play a role, but I could have missed something.

I’m not sure if the OP ever had this resolved? I’m having the same issue, where I have walled off early with cannons, floating void rays nearby to make sure flyers grab aggro, then a-move once I have a large army, but I am still not having the achievement register (even though I’m certain Alarak pushed straight to the finish once we started).

1 Like

At the end of the mission there is a stats page where the “distance Alarak pushed back” (or something like this) is written. Did you check that?

I have same issue. First I Destroy enemy around when the alark shows on map. i build the tower and cannon all around it so I can start push when I form a army. the circle around the alark never went red. stayed white until I was max with army. i push with no problem but i didn’t get achievement. it never been pushed back because of cannon and tower. just like Wyldecard said.

nvm i figure out. you have to keep unit by alark from start until finish.
i got the achievement. but im sure other way should work too. i dont know why it doesnt work.

This absolutely is still occurring and bugged. I’ve tried 4 times now on Hard and have save scummed to perfection. Ensured the way was 100% clear for Alarak and he didnt’ run into a single unit. The achievement is for SURE bugged unfortunately. I’ve gotten 100% in both Terran and Zerg, and now i’ve gotten everything up until this mission – sadly, can’t complete it.

Also - wanted to note – there is nothing in the statistics page at the end notating the "distance Alarak was pushed back. This leads me to believe that the achievement truly is bugged/not considered correctly any longer.