Fix the US authentication server problem

You customer service team is keep making an excuse
that nothing is wrong with the SC2 US server
since you have not detected any severe server issues.
But that is not we are saying !!!
We are not saying about the last DDos attack that happened in November!!!

Our accounts’ individual authentication process to US server is seriously bugged!!!
I have 3 alternative accounts, and nothing is wrong with them.
Only one of my accounts has the trouble in the authentication process to US server,
KR and EU server is fine.
And this keep happening wherever I play SC2, then this means that nothing is wrong with my laptop & Internet connection.

How many times do I have to keep reporting to make you team understand what I’m saying? This is my 3rd report.
It is about the ‘Specific account’s Authentication process to US server’, not the overall stability throughout the US server. Am I clear now???


Yep. The issue is account and region specific. It does not affect all accounts. It does not affect other regions for the affected accounts. It’s not a problem for other games using the affected accounts. It has absolutely nothing to do with the computers or networks.

Certain accounts are having major problems authenticating when Starcraft II starts up. Sometimes it takes a long time and other times it takes several attempts.

1 Like

@faker, I have two accounts and both are not logging into any regions. Is that what you’re seeing with 2 out of your 3 accounts?

I posted about this in another thread (see below). Would be interesting to see how many people are impacted.

I’m still having this issue and it is only with SC2.
No other blizz games have this issue and no other non-blizz game does this.
Only SC2.

Please fix devs. This has been going on for too long.


Same here as well. My account on Americas region consistently gets the “connecting to blizzard services” box with the option to play offline as it takes a long time to authenticate. sometimes it makes it past sometimes it fails and makes me login again.

It only does this on americas region. setting to asia or europe logs in instantly
it does it from multiple computers
it does it on my home internet or tethered to my iphone or at a friend’s house
A complete format and windows reinstall did not help
my wife’s account on the same computer and network logs in instantly

This may be pure coincidence/speculation but I swear it started when they implemented the login limitation/queues for D2R.

If there is anything I can do to assist in resolving this let me know. I am tech savvy and motivated to remove this albeit minor nuisance from my evenings

1 Like

this has gotten particularly bad the last couple of days. Today I had to wait for it to timeout four times in a row before it finally successfully logged in. meanwhile switching to europe or asia or using a different account logs right in no problem.

Hey thel,

If this issue is only affecting one specific account and one region only, I’d recommend submitting a ticket with the details. We can have someone from support test logging into the account to see if the problem can be reproduced on our side, and if so at that point the Starcraft II team would need to fix the account itself.

thank you for the suggestion Jambrix. I’ve submitted ticket US82790334. We’ll see what they come up with. I imagine it should be easy to reproduce since it does it to me no matter what computer or connection I am on.

I’ve also got a ticket I submitted three months ago: US81746130

Support was able to confirm that they had the same issue when trying to log into my account from their own systems and network.

It was marked resolved and archived with no assistance or actual resolution.

Not sure what I’m supposed to do now.

yup same just happened with mine. Hopefully MS can take over and get them to fix their stuff because support is not so great right now. I just came out to check this thread to see if there were any updates as I was sitting waiting for it to login and it eventually gave up (once again) and dumped me to login screen. I mean really who uses the in game login screen anymore? quit out to launcher and back to waiting as I type this.

I am also getting the same error messages when trying to play SCII.

Hey there HyperTurtle,

It looks like your account was added to a tracking for this bug. Since these types of errors are handled by our engineers and devs instead of our support staff, we can only provide updates on the topic.

For folks who are not already on the tracking we do still recommend submitting a ticket to ensure your account gets added.

Thank you.

I appreciate you checking in on this. Hopefully something comes of it on the dev side of things.

Hello, I have begun experiencing this same problem for a couple of days now.

This account cannot login to the US servers. I have tried the EU and KR servers and I can login just fine.

EDIT: Login using the app is OK. Manual login in the SC2 game does not work.

1 Like

Same here.
I’m experiencing this problem right after the scheduled maintenance on 4th of February 2022. I can connect to the EU and KR servers fine, but not the US server. Any help would be appreciated.

For me I can now connect via the app. Previously I bypass the app and login directly in the SC2 game which is still bugged for me.

2 posts were merged into an existing topic: Starcraft 2 is saying battle net is down [Main Thread]

Getting the same authentication error in the US region. Temporary outage, blah, blah. Other regions are fine. Blizzard, when are you going to fix this crapola?


same here its ya boy from edmontoni get the same message :frowning:

I have the same issue. Been through all CS asked for and nothing worked.