Compiled 10th Anniversary Achievements Tips / Issues / Bugs

band of brothers also seems to have new triggers, allowing for production of medics, mines, and auto turrets.

ah damn just when I find an easy way to do Warp Incomplete

Most issues seem to be fixed:

Looking for advice for holding out for 2.3 mil zerg in protos (it gets too overwhelming after 1.8mil) and 200 zerg killed by spider mines in nova (best i’ve done is 120). These two I’ve been struggling with (i completed the rest)
Edit: got 2.3mil with nexus overcharge, annihilators, and dragoons and some DT’s in front of nexus-walls. Started dying just as I hit 2.3mil, had solar lance mostly for clearing the air lane but was good for getting a good hit on all the other lanes occasionally
Edit2: got 200 spider mine kills, guess all I needed was to get an extra command center next to the ally base and destroy their refineries like Garbo said.
Would put 9 or so mines just down the zerg ramp and lure out a bunch of zerglings every so often.

2.3 mil zerg, just keep about 8-10 dts on the left, right, and bottom exits in front of your cannons and they take care of almost everything.

For the top exit, if you have enough cannons and shield batteries, have stalkers at the front constantly baiting the guardians back into cannon range and actively use blink. You’ll need to keep replenishing stalkers and actively controlling them, but it’s the only part of the map you have to pay attention to, the other exits will be managed just fine by dts and cannons.

For spidermines, just take 1 or both gases at the friendly base and keep making reapers non stop. Set up mines at the ledges to get the lings too. At the bonus areas on each side of the map, the worms also keep replenishing forces. Just don’t allow your reapers to attack, just queue them up to lay mines and exit the zone, the mines will do the killing instead. If you really struggle, just save, wait for the wave to see where they’re going,a nd then reload and put down the mines on the path. Don’t cluster them all together or they all get triggered at once, lay them one at a time down the path.

1 Like

Thanks everyone for a great time exploring the problematic achievements. With the patch that has just gone live, most of the problems are resolved. The only missing 2 do have workaround methods that ‘should’ enable anyone to obtain them as well. So I guess except for the few more challenging achievements (that some may have), I am officially not going to update this thread anymore haha.

Overall, it has been fun exploring how to workaround the bugs. It sort of reminded me of how gaming was in the past, when you only had a CD and patches do not exist. Whatever bugs the game came with, they are going to be there, period.

So rather than just complaining that things needed to be fixed / changed (aka what I call spoon fed; and yes I am referring to 40% of the threads and posts that basically ask developers to ‘fix’ / buff / nerf pretty much everything), gamers really needed to theory craft and workaround or even utilise other bugs in order to get to the goal.

I do truly believe that this is what gaming is truly about - solving problems, and this anniversary patch reminded me about the roots of gaming again.

For those of you who had the chance to walk this journey together, I hope you never stop exploring new ways whenever you play SC2 or even any other games.

Cheers and keep gaming!


Regarding the Disintegration Doctrine achievement.
I had to load a save about 6-7 times before it worked, I tried the fog of war cheat to check what I was missing but there was nothing missed. I tried different ways of ending the mission with different enemy units still alive.
The one time I actually got the achievement was when I actively hunt down the carriers on the top left and right outside the terrain. You can reach them standing close to the edge and bait them under the terrain to kill them.
Perhaps carriers creating interceptors or something makes the achievement unavailable. Don’t know but worth a try if you can’t get it done. Also killing the last structure right after killing Narud might have been the answer as well, good luck.

I’m very much questioning that the Templar’s Charge achievement has actually been fixed. Played through it three times now on the new patch and I’m 99.9% sure I didn’t lose anything other than interceptors and I still didn’t get it. The third run I even made sure I didn’t lose any buildings either. Still seems bugged to me, no matter what the patch notes say


I did that achievement a few hours ago and I had to load a save because I lost a pylon to some Wraiths so be careful to not lose any buildings. I made 100% carriers and I got the achievement. Like the issue with a few other achievements perhaps it works if you load a save and finish the mission then you load a save and finish the mission again and so on a few times and hope it works.
If that doesn’t work just re-play the mission and be careful!

I’m beginning to suspect that there is something different altogether buggy about this achievement. I’ve played this mission EIGHT times in a row now without losing units and still not getting it. Done it several times with both carriers and void rays. Never built any buildings other than assimilators outside the moveable platform and made absolutely sure none of them got destroyed. Hotkeyed literally everything I had into different control groups just so I could look at the number of entities in each and compare before and after to be 100% assured nothing got lost off-screen. I’ve taken pretty every precaution I can think of so at this point I don’t really understand what’s wrong


Sometimes the achievements doesn’t show up but you can see them in the “recent achievements” on your in-game profile. You don’t have it finished but it just didn’t show up? Happened to me a few missions, like the one where I had to pick 18 resource packages within 3 minutes. It didn’t show up at all that I finished it but when I looked on my achievements I had it completed.
Otherwise I have no idea. :frowning:

Yeah no I don’t know what to say. Did it a 9th time, another perfect run but still nothing. It’s not really a matter of missing something on the minimap after all this; it simply isn’t working as intended

I saw posts of people seemingly opening up the achievement triggers in coding before the hotfix; I’d be curious as to what they actually say for this one now after the update (not entirely sure how to do that myself). Something clearly is still bugged with it, but I’m struggling to figure out what. I’ve done all the new WoL and HotS achievements as well as all the LotV ones up to this point but as far as I can tell, this one just seems outright impossible to complete atm

Either that or maybe achievements in general just aren’t working right now due to battlenet issues. Can’t say it looks like there are any though

Woah okay, 10th time’s the charm apparently. Finally got it

So it turns out you cannot complete any of the secondary objectives. If you destroy any of the Hybrid Stasis Cells, the achievement won’t fire. I just decided to test this because they are technically a different player in the scenario (yellow in contrast to the red terran), so presumably the scenario has now been coded to check for any non-terran casualties (excluding interceptors) instead of specifically protoss/player casualties. This is similar to the error with the achievement on The Dig previously where it didn’t work if you used the laser drill on any of the neutral temples (optional objective)

Sooooo yeah, I got it, but this is obviously not intentional and should be patched. Again

Oh yea that makes sense because I didn’t do the bonus objectives when I did the mission! Glad you got it.

Thanks for all you did here, Kyrie! I don’t think the fixes would have been as quick as they were without all the research you complied here.

This is interesting!

In the initial version, I simply made an exclusion for Interceptors in the achievement triggers. During the test runs, I did do the bonus objectives and was able to meet the achievement criteria.

When I get home tonight, I’ll open the patched version and see what Bliz changed, and do a few test runs to see what/when the fail occurs. Perhaps they introduced a new bug when fixing the old one.

Well I can only tell you my personal experience with it; don’t know anything about what they coded and how. But I did play the scenario 10 times in a row; the first 9 of which I always killed one or both of the hybrid stasis cells and didn’t get any achievement, and then the first time I tried skipping it I immediately got it. Seems a bit unlikely to me that that’d be a coincidence at least but I can’t say for certain

You’re probably onto something. It’s not unheard of. The achievement for “The Dig” had the exact same issue.

Yeah that’s how I even thought to try it in the first place. But it was easier to figure out on The Dig because there the kill count for the laser was specifically listed on the post-game summary screen. Here there’s no direct indication for the amount of “units lost” that’d discount the achievement so there’s more guesswork involved

Hey Guys, found another “bug”, if you don’t defend the last attack on the “Spear of Adun” Mission and got Buildings destroyed while the cutszene ist playing (even if you ended the mission before the attack arrives), you won’t get the achievment. I highly recommend you, if you choose this tactic then: skip the cutszene and you get the achievment “You Must Defend Additional Pylons”

1 Like