Compiled 10th Anniversary Achievements Tips / Issues / Bugs

Glad you pointed this out.

The actual achievement in English is to destroy all Zerg structures before freeing all captive Protoss. There are a total of 3 sets of Protoss captives too free. So as long as you destroy all the enemy’s structures before you free the 3rd set, you should be good.

So I’d recommend that you play normally until you reach the 2nd Protoss captives and rescue them. This way, you will get a 2nd base and also some time to build up your forces. Once you deem it to be sufficient (and have saved), you wait for Kerrigan to move out before sneaking behind her to hit the most forward Zerg base.

Once you get this first forward base down, the Zerg basically comes to a halt. They will stop pushing the Terran base and you will get all the time in the world to mass up and then hit the other bases. The key to note here is not to rush too much because the Terran’s final base is rather well defended and should be able to take 3-4 waves at least.

1 Like

I am feeling a bit stupid. Anniversary achievements shall be completed on normal+. When I use my Mission archive I only have “normal” speed as the lowest speed setting. Is it possible to do the achievements on Casual?

Just one thing to point out: you don’t need to destroy all zerg bases.
I’ve got the achievement after destroying the most forward one (to stop zerg from attacking terran) and then the first one (where the resources are) — and that was enough, though I haven’t even touched the central one.

Achievements require Normal as difficulty, not as game speed. There are no requirements for the game speed, you can do them even on the lowest speed setting.
And no, you can’t do them on Casual. Either Normal, Hard or Brutal.

I complete the Moebius mission in 3.22, with killing the north egg. The issue is that there is an egg hatching at 3.15 at the southern hatch. Is this because I play at normal difficulty? There are actually three eggs with lings at that hatch, the first two both hatch before 3.22.

EDIT: I missed that I was not supposed to kill anything near that last hatchery. If I do not kill anything, no eggs are spawned and it worked. Now completed all achievements!!

I got really mad and I found out that speed options vary with Releases

  • Wings of Liberty has slower and Slow option on Normal difficulty
  • Hearth of the Swarm / First Void set have slow on Normal difficulty

“The infinite Cycle” however belongs to Legacy of the Void Main Story and it only has Normal speed as the slowest speed available. Thus the hint to use “slow” does not work.

Well i did in 3.29(no stims confirmed :smiley: ) anyway @ #2 eggs spawns twice once you finish #1/and timed and second one if you kill broodlings+ 2 zerglings/not sure if while roaches, after nydus spawn but if marine stay at maruders starting location than the second egg won’t hatch at least i had this “various” and @ #3 you rush to target without killing anything else, except corruptor if you want/need to, anything else force to spawn eggs @ #3.

Edit:
Hidden Victory (10 points) – Complete the “Amon’s Reach” mission by constructing only Probes and Dark Templar on Normal difficulty.
confirming support forces from Warp-in Reinforcements does not fail achievement even with kill air units.

there isn’t much i thought 2 on begin the less you trigger the better for you
here is video of Nuke that helped me a lot and i didn’t had stims researched :smiley:

well this video is same ^^ like other but i dont get it… i dont understan why he alwas reload.,…

maybe blizzard will fix it… or need wait 2 3 month for next upgrade?..

well look closer he failed few times and in description you got timings for next time of well played part, it bugged but viable. And you saw his fails also to learn, eggs can’t hatch, this is main bug where them counted as training units, bug or not it always less timer to 8h normal run :slight_smile:

Just kill the second egg too. This was happening to me and I just focused it right after the broodlings were dead and shift+attacked the data core to finish killing that. The destruction of the second core is delayed but it still dies before the third core so everything works out.

~https://i.imgur.com/GqLijzf.png

Thanks everyone in this thread for all the pointers, finally got the achievement today.

Kills with mines are absolutely easier on hard, with 1 gas stolen I got around 240 mine kills with laying mines after a waves spawned.

Hi there,
About Disintegration Doctrine
I think it really is that part:
It is possible that the trigger for achievement needs to be checked again so try to kill another unit in the moments after you killed Narud. (Test this first, most likely theory.)

I had no luck doing, so I checked map in editor, and the trigger for this achievement is “Any unit dies”. Probably Narud is not a unit, so the conditions are not checked upon his death. What I tried was I destroyed all structures but I left plenty of units (with time freeze) in the 1’ area. I destroyed structures before Narud but didn’t attacked him and left that to allies and moves all army to the area with enemy units and just when Narud was about to die I attacked those unit to increase chance to kill some between the short sequence of Narud’s death and mission ending.

And I got the achievement with this.

I played this for 45min, killed literally everything. Had to start killing the evacuees so the mission wouldnt finish too soon, things got real messy. Wish i had let the mission finish sooner or come here first.

Just got Disintegration Doctrine. I quicksaved at around 26 Minutes and tried around a bit. It seemed most of the time i killed Narud too fast. I let him to the NPCs and killed other stuff in the meantime and got it. Maybe its intended that Narud spawns anything during the encounter and thats why carriers are too fast. Also, like Honza mentioned before, I tried to have some kills as late as possible. I think I killed a Raven in the moment Narud died.
Hope this helps :slight_smile:

Modified the first post since there are more reports relating to this matter. No point having a lengthier one with too many difference scenarios. Will leave it as such until proven via map editor (somehow) or with a more concrete report on when the unit should be killed.

It would also appear Nova is bugged - at least on darken the skies when using the darkblade gun whenever using Q she drops her weapon and take off her armor, she can still use abilities just loses her auto attack and armor benefits.

1 Like

Indeed. There’s quite a few reports of that sprinkled around.