Can't get several achievements '10th aniversary

I can’t get 3 achievements from the ‘10th Anniversary’ category

I tried to get them many times, completed missions several times, fulfilled all the conditions, but they simply simply are not done. The other achievements seem to be ok, cuz i unlocked them all.
List of achievements, that i can’t get:

  1. Contract saviors
  2. Warp incomplete
  3. Desintegration doctrine

Please fix this problem. I want this commentator.

Contract Saviors is bugged right now.
Warp Incomplete counts the warped-in units during the first shrine activation for it’s achievement, so you need to kill the Zealots and Colossi that are warping in from the entrance.
Desintrgreation Doctrine, you have to wipe the map. There’s two areas everyone misses in the top left and top right of the map. Also be sure to scan over the map before completing the mission. You might have missed one or two void structures.

Got it about the first two achievements, thank you.

I’ll try one more time about the desintegration doctrine, but i’m pretty much sure about those two top corners. Dont know what have i forgotten, but anyway, thank you :slight_smile:
waiting for the fix!

Hi, you might want to make sure that there are total 3 rafter (2 on path, 1 on very bottom right which might not able to see). I tried this way but still not pass yet. Hope this can be helpful.