(Abandoned) Consolidated 10th Anniversary Achievement issues

The achievement “The way of the Nerazim” (Wings of Liberty, mission “A sinister turn”) drove me mad while using German translation.
Because they forgot the part “with dark templars” in German :-/ Any way of reporting that as well? I now changed to English to see that, because some people wrote “Just follow the description”.

I’ll add it to my list above. Thanks!

FOR QA: Adding this achievement to my list above:

Wing of Liberty

The way of the Nerazim - Kill 30 enemy units or structures with Dark Templar in the “A Sinister Turn” mission.

  • There’s a report that the German translation of the description text is missing the “with Dark Templar” portion.

“Manually” tracking this, to the best of my abilities, none of that happened. Is there a fool proof way to keep track of lost units?

Not from within the Campaign itself. Most you could do is use the editor to alert you when something dies, or do something that fails the achievement. Then do a few play throughs and see what happens.

I did a test in the editor which informed me if 1) I did the bonus objective, 2) any Interceptors died (they are allowed to), and 3) I picked up any of the floating minerals.

With all of those being true, I still got the achievement:

Were you able to get it? If not, I made a test a map that will help highlight what is causing the achievement to fail.

Hello there, I’m having a serious issue with the Nova’s mission where you need to kill 200 enemy forces with spider mines.
I currently on my Eighth run on this mission, tried both normal/hard/brutal difficulty on this mission and at most, I’ve been able to kill 168 enemies. And i’ve been building anything but reapers when I could so I had the biggest mine field.
I tryed different layout of minefields but still, I can’t reach the 200 kills with them. Most the enemies won’t die to a single shot and they don’t walk as a big bulk but one by one when stepping on a mine. With not enough damages on roach for thoses mines, I’m out of concern for this achievement. Too bad it was my last one needed.
Maybe you’ll plan on a fix here ? a change maybe ?

There’s been reports of players getting that achievement on all three difficulties. For example,

I suspect it’s less of a bug and more that players are still discovering strategies. If you search around this thread, there are some ideas.

For QA:

You may have already looked into this but I figured I’d throw it out there.

For Disintegration Doctrine, I slightly recoded its triggers to allow the achievement to be awarded more consistently (when the conditions are met, of course).

Below is the summary of what I did

  1. Disabled the following triggers (which you can observe in the triggers module):
  • “Victory Defeat Narud Completes”
  • “Achievement - Destroy all enemy structures and complete primary objective in less than 28 minutes”
  1. Using the components of those two disabled triggers, I assembled a new trigger named “Anniversary Achievement - Check Criteria upon Narud’s Defeat”.

So far in my testing, it appears to work fairly well in both awarding the achievement when it should and not when it shouldn’t. Anyway, here’s the test map. Take it or leave it! :slight_smile:

[Link removed now that 5.0.3 is out]

Adding this confirmation to my OP above:

Legacy of the Void

2. You must defend additional pylons - Complete the “Spear of Adun” mission without losing a structure.

  • The fact that your base is supposed to get overrun (in the cinematic) as part of the story precludes the achievement.

Adding this to my OP above:

Legacy of the Void

You must defend additional pylons - Complete the “Spear of Adun” mission without losing a structure.

  • Confirmed that losing a structure during the end of mission cinematic will fail the achievement.

  • Using the “Structures Lost Score” isn’t differentiating between structures lost in the mission with those lost in the cinematic:

Quick check, what mission is this? :slight_smile:

Spear of Adun. The “You must defend additional pylons” achievement. I removed the player quotes in my OP to make it less confusing.

Yes, I completed Raszagal’s Retribution. I used 4-6 Dark Templars to do most of the dirty work to clear out bases. I rescued the first 2 groups of troops, and then went to work making mostly immortals, but a few colossi, stalkers, and zealots. I built a new base near the 2nd group of troops rescue location in lower right. Then using DT’s cleared out the pathway to attack the 3rd (farthest) zerg base . Once that is cleared, the attacks on the humans will stop. That gives you time to rebuild your forces and once again amass immortals, some colossi, a few stalkers and zealots, and attack the first zerg base. Once defeated there, build 2 Nexi and 3 assimilators, build up minerals and vespene and rebuild your army again. When rebuilt, attack the middle zerg base, and you should be able to get the achievement. It is time consuming, but it worked for me.

I discovered a bug that makes an achievement too easy, haha… someone might want to test this, though I can’t imagine it was just me:

In Heart of the Swarm, the achievement “Salivary Conditioning”:

“Destroy 20 Dominion structures in the ‘Planetfall’ mission before the 3rd Bile Launcher lands on Normal difficulty.”

I had taken out two bunkers - and nothing else - when I checked my achievement progress out of mere paranoia.

I had already been given credit for something like 12 structures destroyed.

I am all but certain why this happened: the mission gave me credit for the Dominion structures destroyed in the mission’s opening cutscenes, where Kerrigan bombs into the planet personally, and it immediately blows up the entire Dominion base whose area becomes the player’s Zerg base when you gain control.

Probably worth testing, but that’s gotta be it - it’s like the issue with the Legacy of the Void 10th anniversary achievement for “The Spear of Adun”, where you’ll fail the achievement if the enemies destroy one of your structures in the ending cutscene. Same deal here, but in reverse - I received credit for that bombastic, cutscene-only destruction of an entire Dominion base.

Anyway, I don’t know how to test/prove that, but I know I hadn’t touched a single enemy base yet. Just two bunkers. There’s no other way I’d have credit for roughly 12 buildings destroyed at that point.

Also, I have a separate question about the Legacy of the Void achievement “Big Spear Diplomacy”, which I haven’t done yet:

I know “Reconstruction Beam” is bugged and will fail the achievement, but can I still get the achievement if I pump solarite into the passive systems for Starting Supply / Shield Recharge / Structure Warp-in Speed?

Or do I have to leave those passive systems completely unpowered, too?

There’s been a few reports of the auxiliary systems not affecting the achievement. Somewhere I saw a post that said they had all 3 categories maxed out and they got the achievement no problem.

1 Like

Cool! Thank you so much for elaborating, Leviathan! Much appreciated. :slight_smile:

I have a issue with the achievment on
( Wings of liberty Zeratul )
The Way of the Nerazim “A Sinister Turn”

i can destroy all units and buildings and dont get the achivment =(

okay i got it… in the german translation they dont tell u that about Dark Templar only -.-

With the fixes in patch, I’m abandoning this thread. If issues persist or new issues are found with any achievements, I’ll start a new thread and link it here. I’ve updated my OP with the new fixes.

New thread: Consolidated 10th Anniversary Achievement issues