RTX 2080 TI i7 8700k

Hey guys, i have a question. My previous setup i have a gtx 1080 amp extreme+ i7 8700k overclocked to 5ghz, getting 300fps most of the time with only few drops to 280.
Now i have rtx 2080 ti aorus extreme with same CPU, and i’m getting drops to 220fps and 240… in some maps its even worse. do u guys now any fix? or is just a bottleneck? i tried everything: Drivers, spacial sound ON, etc… i dont know what else to do.
I play on 1440p with everything on low, 100% Render scale.

This type of question is better asked in Technical Support

i have 3 theories:

1.- 2000 series suffer of heavy overheating so please double check the temperatures of that GPU

2.- When you installed the new GPU you did a BIOS reset? maybe this reduced your RAM speed this game need at least 2800-3000 mhz + ram in dual channel to keep that brutal high FPS so double check

3.- 2000s series drivers are not good optimiced yet. So you have to be patient for now play at 1080p if you want hit 300 FPS all time


1 - In full Load the gpu gets 80°C max. The problem is, in other games like tw3 , rise the tomb raider or assassins creed odyssey the fps is normal, i can play 4k 60 fps… but in overwatch, it has this random drops on 1440p low settings

2 -i did not, but my ram frequency is 3200mhz according to CPU-Z. 32gb Trident-Z CL-18

3 - Yes… i hope its a driver problem. I tried play on all lower resolutions above 1440p and the result is still the same, drops on team fights to 220, 240… dont know what i’m supposed to do.

I had a similar problem up until recently, in many games would I be getting stutters and sudden fps drops for apparently no reason. Over the course of about half year I would try everything, I would lower any possible setting, I would get rid of every background stuff there is out there. Nothing helped.

In Overwatch I didn’t stutter, but my fps would be lower than usual, going below 200 at times (I have 240hz monitor, so 180fps is a drop I can feel)

Then I found a random reddit comment suggesting to someone else to turn off Hardware acceleration on Discord. That did it for me. Now I have no stutters, overwatch is working great again (never drop below 250fps).

Thought I should mention that, as it is possible you’re facing the same problem I was for so long. Hope this helps!

Edit: thought I should mention, I have 1080Ti , i7-7700 and 16gb RAM

1 Like

You can try calculating if the i7-8700K is bottlenecking your RTX 2080 Ti vs the GTX 1080. I think that it would marginal to the point of being not an issue.

Have you tried updating the GPU BIOS via the Aorus Engine application?
Also, on the same Aorus Engine application, i would recommend switch from Passive to Active Fans.

i assume that you were playing OW at 100% Render scale @ 1440p on the GTX 1080 as well?

1 Like

No bottleneck, i already used this website. GPU BIOS and Driver are updated by the Aorus Engine too. And with gtx 1080 amp extreme i used 100% Render Scale @1440p everything on low aswell

1 Like

Can anyone actually explain in a rather good metric where exactly that much FPS is even providing any benefit at all?

Personally, if you are running an FPS higher than your refresh rate by too much your just wasting effort. While other things online latency will be more crippling than the idea of saving on input lag.

So, for 200+ FPS it seems you shouldn’t put too much effort into it when you reached the benchmark of >144 hz for a monitor at best. Plus, you have the 2080 for future when/if games start to use the new 2080 features which set it apart from the 1080.

1 Like

in overwatch with 300 fps u have less input lag and the sensitivity is different too.
EDIT: Btw, i already tried disable hardware acceleration in discord. Still the same problem

That’s sort of hard to believe. 300 -> 240 fps is <1 ms difference. At 144 hz monitor update rate is 6.9 ms per frame. That means visually your body will not receive any feedback that something is different unless it happens to be >6.9 ms. I suppose it might lay on some boundary where the refresh rate is not sync’d to the fps rate.

Otherwise, the only physical difference to body reaction should be in terms of the audio which I am not sure how that works in terms of speed, but otherwise most internet connetions might range from 15-45 ping which is 15-45 ms. So, the server should cause way more annoyance for someone than <1 ms input lag.

Anyway, I am trying to say you should try to not worry about it. Enjoy the game. I think its a placebo really. Enjoy the night.

1 Like

Yes, i did not think that an OC-ed 8700K at 5ghz would bottleneck a RTX 2080Ti.
So it is indeed strange if you are getting FPS drops as bad as you are.
I am running on an Aorus RTX 2080 Extreme and i can hit 270+ fps (altohugh i cap it based on my monitor’s, Acer Predator X34P, max fps) on High to Max settings but at a lower Render Scale .

I did not try out Low Settings on 100% Render Scale because Render Scale affects framerate more than settings do. Of course, that does not answer your question on why the RTX 2080 Ti is outperformed at the same Render Scale and Settings compared to the GTX 1080.

My only guess is unoptimised drivers.

Aorus Engine had an update a day ago and NVidia also just released a new driver 1-2 days back. You tried both?

btw, on “Scan” and “Active” fan mode, the Aorus Engine managed an auto overclock of up to 1950mhz for my RTX 2080 extreme. Just something to share. That the latest version of the Aorus Engine looks to improved.


yes… i updated both. The GPU Clock goes to 2040mhz by himself, so i think its not a GPU problem… i believe is just a thing with overwatch, because in cs for example i get the same performance i had with gtx 1080, playing with lower resolutions aswell. Btw, what are your settings to get 270+ fps?

1 Like

The only thing i could think of was the raw GHZ difference between the Zotac and the Gigabyte GPUs. Because based on the official specs off the websites, your old Zotac was running at 1911mhz while the Gigabyte is running at 1770mhz.

Then, of course, now you mentioned that boost clock is running at 2040mhz.
Unless the Zotac was running faster than 2040mhz.

That said, boost clock are bursts of speed and sustained only through the stability of the thermals and extra voltage supplied. It is likely that Zotac was able to sustain a longer duration for the boost clock than the Aorus.

For the settings, i would have to double check and get back to you, i cannot really remember except that it was on 50% render scale, but i believe that it is probably at high settings.

P.S. Yes, it could be that the game or the drivers are not optimised yet also.


I noticed that the GPU usage on rtx 2080 ti aorus is 45 - 60 % max, and in 1080 zotac amp extreme was always higher than 90%… but that’s one thing I can not change because of the game engine. I play with the afterburner msi on and the gpu clock variation is at maximum 1980 - 2040 mhz. Zotac i remember its around the same clock speed…

1 Like

Hey, GohanBlanco. Thanks for waiting. Just did some screenshots after I got home:

Screenshot of my settings:


At 100% Render Scale


At 50% Render Scale



Hmmm…obviously, OW is not taxing the RTX 2080 Ti Extreme and rightfully, at Low settings and 100% Render, it really should not.
Still it does not explain why you are getting the frames per second which you are getting for it versus the GTX 1080 AEx.

I personally think that it boils down to the driver and game optimisation.
Although that does not explain why I am getting the framerates I am getting versus yours because all RTX share the same driver.

For reference, I am running the game on:
CPU: i7-8700K @ 4.5ghz
Mobo: Gigabyte Aorus Z390 Eilte
GPU: you already know
RAM: 32gb DDR4 3000mhz @ 15-16-16-36, KLEVV CRAS 2
Storage (for games): Adata NVMe M2 SX8200 Pro 960gb SSD

By all accounts, you should be hitting better frame rates per second than I should.

1 Like

Your frame rate in the practice zone is going to higher then in game vs bots or people. You are also running with triple buffering on which will up your fps a bit at a cost of input lag. I personally suggest turning shadows on at least low and turning dynamic reflections, fog details and triple buffering off for your setup for looks and high fps.

For sure this plays a part. Not much you can do about the game but you can reinstall your gpu driver and use DDU to fully remove your old driver first. I also personally ran into issues with the 417.35 driver for pascal for overwatch (not the latest driver anymore) so it very well could be your driver.

Side note, it feels random to me, on a patch that I may have to tweak or deal with fps issues of some sort when a patch comes out. Sometimes i have no issues and other times game turns into a fps dropping stutter fest for w/e reason. Sometimes deleting the overwatch folder with the settings in it (from documents) helps but not always.

There are a ton of things you can list, I linked to my old list in this post which also has things you can try if you want to dig deeper. Here is the link to that post.


Thanks for the observations, advice and link, Geletrode.

I hope that it would be useful for GohanBlanco.

I personally have no issues with gaming at 130 frames per second. I cap the framerates to the monitor. Bought the RTX 2080 and the Acer Predator X34P to play other games. Soulcablibur 6 at max settings @ 3440x1440 reso with 200% render scale runs buttery smooth and oh so gorgeous. Not to mention, breathing new life into Final Fantasy XIV as well as games like Pillars of Eternity, Tyranny and of course WItcher 3. Ultrawide is like…wow…

OW is casual for me, at best. So the current settings were basically set after experimentation for a constant 130 fps in a match. Yeah, apologies to the teams when I was busy monitoring the fps.

So far, personally for me. When I install the NVidia drivers, the option for “Clean install” always works well for me. Although, yes, I am aware that the old drivers could still be lurking in the registry, for sure.

Omg man i love u! I used DDU to uninstall previous drivers and install the most recent one and now is hitting 300 fps constantly!!! The CPU usage is lower too, so the problem was the driver… thank you and @silenthill for helping me with this. Can’t thank you both enough!! :smiley:


Glad you have it all worked out, GohanBlanco. =)
Credit goes to Gelectrode, for sure. =D

1 Like