GeForce and and Overwatch

I have a brand new system since last Tuesday (and still downloading 5 days later… godamn you huge games and (comparatively) slow ADSL2+ :open_mouth: )

At any rate it has an NVidia video card and GeForce Experience comes with it and it claims it can “optimise my games”

Now… is that a good idea?
Any success or horror stories to share?

The GeForce Experience app is believed to contribute to unstable system performance with Overwatch. Not to mention Overwatch provides quite a number of different options to tweak performance without fudging with third-party tools.

The only reason you might want GeForce Experience is to automate driver updates but there are other options.

Congratulations on the new system!


I personally don’t use that system to optimize ANY games. You’re better off just setting everything to max then start lowering parts that impact your FPS the most till you get to a solid FPS you want. I’m at 144 with my 1080.

First time I’ve heard of this. Also I haven’t had any problems since OW launched.

It’s ShadowPlay recording system is pretty great. Now I don’t use it for streaming but having the ShadowPlay to capture the last N seconds/minutes of play is amazing. I have mine set at the past 1 minute as that’s always enough to get whatever funny moment occurred in my games. These are about 800-900 meg video files at high quality setting.

The driver itself has built in optimizations for certain games. Anything Geforce experience does isnt really necessary for the best performance.

Just throwing this out there, but if you run Windows 10 it has this feature built in (GameDVR). It works great - at least does for me. (And also despite claims online I’ve never had it cause any performance issues)

The specific error GeForce contributes to, and I personally experienced multiple times, is ‘rendering device lost’; the error can appear from other causes and contexts but the ‘rendering device lost’ error has been well-documented to happen if you have a factory-overclocked Nvidia GPU running using the settings profiles provided in GeForce Experience.

A common fix is to use a third party app to delete the Overwatch profile inside of GeForce, which I’ve had personal success with.

Yeah… Shadow Play shows an annoying popup (although, only at the start) wonder how to deactivate it…
(And I was using XBox / Windows 10 back recording anyway!)

Check the settings inside of GeForce, it’s a checkbox inside the options IIRC

EDIT: by which I mean the internal program settings, as opposed to the profile of the game

Avoid GeForce “Experience” like the plague…

1 Like

I had that error once and it was because I had 2 copies of the driver installed. After removing them both and doing a clean driver install never had it again.

You can toggle various ones on and off from within the overlay settings.



I don’t think there’s much wrong with GeForce Experience other than it takes up some memory if you are short on that.

It’s recording features are crisp, and the optimization settings are only recommendations based on your hardware that you can easily overwrite. It’s not like it’s forcing you to do anything.

Not gonna repeat what’s been said about GeForce experience as it’s been stated excellently.

Here is another tutorial on how to increase and optimize performance in Overwatch as well:

Dunno what kinda monitor you’re running, but even if it’s sub 75hz an increase in FPS is beneficial as it’ll also decrease your input lag giving you a much snappier feel to the games actions.

Few other things:

If you have Windows 10, disable “Game Mode” by going to Settings>Gaming>Game Mode and switching it to off. It’ll prevent Windows from auto “optimizing” your games.

Another thing to do to increase your performance is to set your power settings to a performance mode utilizing your rig to its fullest. Settings>System>Power&Sleep>Additional Power Settings (left hand column) and then chose either Ultimate Performance or High Performance.

Anyone got any Nvidia Control Panel settings to share with OP? I’m afk and can’t share my presets. I’ve got mine tuned for Performance.

Here are mine (running older Drivers, new ones won’t work with Rust for some reason, but these should be consistent across all drivers):

  • Maximum Pre-rendered frames: 1
  • OpenGL tendering GPU: (select your GPU, don’t use default)
  • Power Management Mode: Prefer Maximum Performance
  • Preferred Refresh Rate: Highest Available
  • Texture Filtering - Quality: High Performance
  • Threaded Optimization: On
  • Vertical Sync: off
  • Virtual Reality Pre-rendered frames: 1

You can keep textures high in game as they don’t impact performance all that much, so your game will still look good :+1:

1 Like

what u do you want? Quality or FPS?

The biggest issue is the OW engine gives a really inconsistent FPS, and Windows adds lots of useless apps and features that drain performance, but some of these apps you can delete.

And windows 10 has by default bad mouse settings and because of that you wont have a 1to1 X/Y ratio but this also can be fixed.

well I run Overwatch on ultra setting at at least 133Hz, so Overwatch is fine

But for exampletake Assassion Creed… on high quality graphics setting run on average at 61Hz with some low at 30Hz… I’d like to be 60Hz min all the time! :open_mouth:
But I do like my high quality graphcis, not sure what I could tweak with least possible visible impact…

lol, I don’t even let let Windows 10 auto-update, let alone let GeForce Experience automatically updates for my system. There have been cases where their driver made it worse for the game, causing you to have to downgrade to previous iterations.

133HZ??? you mean 144HZ. But i believe u are talking about FPS ( Frames per second ), “HZ” is the refresh rate of your screen.

If you want to play OW to win u want the highest and most stable FPS possible because this will lower the Sim speed and make it stable and this in turn makes it so you become more consistent.

My advice is if you play shooters u always go for the highest FPS possible instead of quality since it will give u a advantage over your opponents.

Like AC titles i do not mind the FPS so i also go for highest quality there.

I mean 133FPS.
I setup the video option to use 144FPS like my screen 144Hz.
But sometimes the game engine can’t keep up and, when I was paying attention, the lowest I have seen is 133FPS.

it’s plenty good enough compare to my reaction times… BUt it’s not that better looking that the lower graphics setting I was using before. not that I can see…

Before doing the following, be sure to download your latest driver, but the plain driver and not the automated installer. And Display Driver Uninstaller.

  1. Restart into safe mode.
  2. Use Display Driver Uninstaller to remove all crud. Restart back into safe mode.
  3. Install drivers from scratch. Select ONLY your audio and video drivers and nothing else.

In my experience, GeForce Experience which always runs in the background and has an invisible overlay on all games that it renders visibile upon activation of a keyboard shortcut, cut my FPS by literally 30-40 FPS.

Delete it, and update your drivers manually.

1 Like

Wow… I was wondering indeed if the geforce experience was detrimental…

EDIT ha never mind, it’s not running automatically… the overlay is more like the NVidia driver. don’t want to remove that,would I?! :open_mouth:

The overlay is not the driver. If you can call up GeForce experience overlayed over your game by keyboard shortcut, it is always there just invisible. If you then disable the shortcut, it is still there but without a way to make it visible. The only way to disable the overlay is to uninstall this junkware completely.