Game freezing with Intel i3 / Dual core CPUs

i’m gonna cry, i just want to play a single match :c


yeah man hopefully they fixed that

I have the same problem with the same specs other than crashing the game completely it heats my cpu to 80 degrees c.

Tengo el mismo problema con las mismas especificaciones aparte de bloquear el juego por completo calienta mi cpu a 80 grados c.

Mine is also freezing (i3 4160, GT 1030, 12GB RAM). Game runs smoothly (I’m playing with almost everything on low), till like 2 or 3 minutes it just… freezes. It doesn’t even lag, just straight up freeze.

Same problem since first beta
i7 6500U

Same problem
geforce 940mx with 2 gb
12 gb DDR4

1 Like

I’ve found a solution that worked for me,i played some matches here and the game don’t have freezed yet.
You just need to enter in MOBO bios and turn off hyper-threading.
Your computer will lose some performance,but you can play the game without freezing
My cpu is a Intel Pentium G4560


Same issue for me here
intel i5 6200u
8 gb of ram
intel had graphics 520

Same problem
8gb DDR3

Overwatch 1 worked great, and now I have a -75% experience penalty.


I’m gonna try it right now


Specs: pentium g4560, gtx 1050, 8 gb ram

wow even after all these responses, and not a single staff to accommodate us. not even a “We are working on it” message. this situation is very irritating


Mine was instantly closing instead of freezing. Ended up reinstalling windows and it fixed my issue.

Someone in another thread said that creating a new windows user just to play overwatch 2 works as well

Tried that, but it didn’t work for me.

Same issue here. 1050ti, i3 7100. Installed to a crucial SSD. Stutters followed by a hard-freeze. OW1 ran perfectly fine, devoid of these technical issues.
Have tried everything under the sun except for: disabling hyperthreading as others suggest, installing it to my hard drive instead of my SSD, or reinstalling windows/playing from a new user account.

Switching to low preset and disabling all dynamic/custom resolution scaling, restarting my game to save these settings, and then playing seems to be the only thing that’s had any tangible change. Whereas before a crash was guaranteed early to mid way through the match, I was able to actually complete a match with these settings (and even finish the last half of one I backfilled into). Crashed the next match I played.

I’m currently trying disabling hyperthreading. But even if this works I kinda don’t think this should be the fix we are looking for


They released a list of issues they are working on and this is not listed there now. This is so sad… BLIZZARD PLEASE NOTICE US AND FIX THIS ISSUE


No mentions about game freezes

1 Like

Can’t try disabling hyperthreading since I don’t have the option in my laptop BIOS.
Anyway i’m not sure this would be any good with the performance loss.

I have the same problem I tried everything still nothing helped CPU i3-6098P and GPU gtx 1050ti hope they fix it soon