Battlenet not launching due to dll. error?

Battlenet says I am missing a DLL file in after latest update and will not launch. Error message said to reinstall. That worked until the launcher updated itself today and now it will not work. Halp!


Have you gone through this support article troubleshooting steps yet?


It worked after a rull reinstall until it patched itself again this morning and the problem returned.

Also seems other are having the same problem over here: [Main Thread] Can't launch the App - DLL error - #16 by Bubba-2735 - Desktop App Tech Support - Blizzard Forums


I had the same issue. I tried downloading the .dll and putting it in sys32 as well as somewhere else but what fixed it (without having to uninstall) was just running the bnet install file again. It resolves the issue.

Also you don’t need battlenet to play, you can just run the OW.exe from the OW folder.

1 Like

You mean dowlioad the installer and run it again with Bnet installed from before? Wont it just download the borched patch once more?

1 Like

Yes, but I am a nerd who holds on to all his install files, because you never know what new horrid version of software someone pushes through that rips value away from the old stuff.

It won’t just install the same thing as before, it should fix your current borked install. The other forum you linked suggests the same thing.

But I did not need to uninstall.

1 Like

Can you try installing the beta version of BattleNet (click the BattleNet icon, click settings, click Beta, and click Switch to Beta.)

I reinstalled over the exsiting installation. It got the launcher to work again for now. Then I will have to wait and see if it updates itself again and the error returns. Is there a way I can force the client to look for an update?

I would rather avoid buggy betas if possible :slight_smile:


I also had the .dll error yesterday. I first tried deleting the folder in c:\programdata, but that didn’t work so I reinstalled. I shut my PC down at night and this morning I got the .dll error again. Ran the B-net installer again and it’s working. I’ll give the beta a go and see how that works.

Out of curiosity, which DLL is missing, do you know?

Just waiting now to see if it comes back when Bnet wants to update again. Not the beta btw.

Sorry, I have no idea what file its missing.

Yep the latest bnet update broke itself. Download the Bnet installer and launch it (don’t need to uninstall your current bnet client before doing this), it will repair your launcher and you’ll be good to go.

1 Like

I’ve had a very mixed history with that repair tool……some times it’s done the job….other times diddly

Having this problem now all of a sudden too

1 Like

Also having the same issue. Got the ‘DLL can’t be found’ message, reinstalled and it worked. Closed it when I went to work and just tried opening the BattleNet app again – got the same error.

1 Like

I’ve been having this issue repeatedly after yesterday’s patch/maintenance. Running the install file again does solve it!

1 Like

I just got this issues aswell. “A required DLL could not be found. Please download and reinstall” Nothing seems to be working. Never had this issue before :frowning:

Same here now. I dont know what to do

dll errors can usually be fixed with a clean install, or perhaps even a repair install. This is not limited to the bnet launcher.


when it’s starting to be an widespread with so many players at once i think it may be an issue lol