Area of the screen has been cut by wrong resolution

I’m playing on mac 15’, my game was started with any resolution that’ve cut my screen and I could only use a center area of the screen, so I changed resolution and now I have access only to left corner and it’s not available to change resolution one more time, cause settings in right corner. Let me know how to fix this issue please

Heya Oddbear,

Do you notice any difference when switching between “Windowwed (Fullscreen)” or “Fullscreen” mode?

Let us know.

I can’t change any settings, I said it before.

I am having the same issue… its like my mouse cursor is 10 x the normal size and will not click half of the buttons like its not actually hitting the icons

Hey there,

Does resetting the game settings through the app help with this at all? This would get the game to re-detect the correct resolution and reset graphics settings.

no it doesn’t help, 'cause it give no any effect on game, all still stay the same.
please can you provide us with more information?? 1 answer per day and I can’t resolve a problem, what a hell guys?

Same problem here, but on a fully updated 16" macbook pro.I did use the reset game settings from Battle dot net client. Relaunched, intro sequence ran beautifully, loading screen, the in the main menu screen, it displays fine, but restrains the cursor’s movement to the upper-left quarter (even less than 1/4) of the screen. Can’t get to the gear for settings…no tab/hotkey access (poor accessibility/design Blizz!).

Can’t change it to windowed mode.

Hey there! I moved this thread over to our Mac Support, since both reports are with MacOS systems. There is currently a known issue with the corner screen/scroll issue for Macs.

Does it help to try the workarounds?

  • Use CMD+TAB and CMD+TAB back into the game.
  • Try windowed mode using CMD+M
1 Like

This day game opened in window mode, idk why. So I changed resolution on my native and now it seems to be work fine.
So solution is to start a game in windowed mode

I just fixed it! I Just tried the window mode by clicking command M and it worked! You go into the game and wait for it to load for a sec and then do that command.