Wild Deck in Solo Adventures

Hi. I have been struggling with several of the Heroic Challenges on some of the Solo Adventures in the game.

Today I tried to start a challenge against Lady Vashj in the Ashes of Outlands Solo Adventures and due to the latest card migration my deck had been transformed into a wild deck, nothing unusual. But when launching the game I am met with an error stating that you cannot use wild decks in this format. Is that by design? I have been able to use the deck in the encounter before and just because of the migration I cannot anymore, even though it is an “old” Solo Adventure from a previous year and standard/core set?

If this is intended, please explain why. If not, please fix this. It is, in my opinion a very weird and not fun design choice to not let you use wild decks in Solo Adventures.

2 Likes

I very much agree with you. As far as I know this limitation only applies to Ashes of Outland, all the other challenge modes allow you to use wild cards. I’m sure that the reason they originally put in the limitation was because they were afraid that with all the crazy combos available in wild that it would be too easy otherwise, and they probably wanted it to be difficult even for veteran players.

But now that half the cards that were standard when the adventure was released have rotated out of standard I think they really ought to change it. There’s not really any point any more to the restriction and all the guides online are written with the assumption that you’ll be using cards that were current when the adventure was new.

3 Likes

You can’t use wild cards anymore, I’ve tried in a couple of other solos. So therefore I’m stuck, sad :disappointed_relieved:

Yeah, what are we spending our money on in Hearthstone? They make changes to the game and rotate cards away. Hey man, I’m not just a source of revenue HS. I want what I’m paying for

For Lady Vashj, I found that a Warlock self-mill deck with Neeru Fireblade worked very well.