Unable to access training grounds in mercenaries

I bought + upgraded the training grounds and entered 2 mercs (including one that I had the coins to craft despite lacking the merc). I have since crafted the missing merc but am now unable to open the training grounds to update my selection. It also appears that the mercs I entered are not gaining experience. I am unable to open the training grounds on windows or on an iphone.


I have been having the exact same issue but have not crafted the missing mercenary. I cannot access the training ground, it highlights when I hover the mouse but clicking on it does nothing.

1 Like

Same issue here:
Mercenaries training grounds are glitched. When they first became available, I had a Mercenary, Illidan, that I hadn’t crafted, but had enough coins that I could craft him. He was showing available to train in the training grounds even though I hadn’t crafted him, so I went ahead and put him into training and the training grounds glitched. The glitch appeared to clear and I tried again only to get locked out of the training grounds again, so I went ahead and crafted Illidan hoping it would clear the glitch. I’ve now been unable to open the training grounds for at least two days.

1 Like

I have the exact same issue, after selecting a non crafted Mercenary card ( for which I had enough tokens to craft) for training in the second training slot the Training Grounds facility become inaccessible and after 5 days I still can’t access it.

1 Like

i have the same problem since the last update . how to fix ?

1 Like

From the “Known Issues” thread pinned to the top of the forum:

Problem is that if you already have that issue (not being able to access training grounds at all) the “hotfix” won’t actually fix anything. And for 22.4 the plan is to only prevent to train mercs you don’t have already crafted. Which leaves people like us, who are not able to access training grounds, out in the cold.

This hotfix did not work for me. I had the situation described in the hotfix (put one merc I owned, and one merc I did not own, into the Training Ground). The Training Ground lights up when I mouse over but it will not open on PC or on mobile. Exiting to the main menu and restarting my client does not help.

If you’re still having issue I would suggest submitting a ticket.


Im still have this problem. Is there any solution now ?

1 Like

Problem is that my ticket was closed without any reply whatsoever from a GM/support staffer.

no assistance :frowning:
training grounds is messed up

I believe the hotfix last night was supposed to help with this.

And man, I really had no idea how poor the Support was for this game, that’s sad.

1 Like

Even after the latest patch its still not fixed.