The Boomsday Project bugged puzzle

I’ve tried playing The Boomsday Project solo puzzles. When entering the puzzle I was currently on

Electra Stormsurge Lethal
A Shaman’s Strength

the puzzle didn’t load.

I restarted the game and now as soon as I enter the game it says “You were reconnected to your last game” and the game freezes.

I also tried logging into Hearthstone on Android phone and something similar happens. The game freezes on the “inn doors” loading screen and the phone displays a message “Hearthstone isn’t responding”.


I got nearly the same problem too today.

I am having the same issue

until this date the bug is still active

1 Like

This is frustrating now, what is going on? I was really hoping they could at least fix issues with the single player campaigns … But they haven’t even acknowledged them publically, let alone stated that they’re working on a solution …

i have this same issue too

I thought they fixed all the bugs because i was able to complete the whole adventure back in July.

Maybe new bugs appeared with the United in Stormwind expansion