RAM loss not sure why

So RAM being sucked up by Hearthstone on Mac OS HighSierra10.13.6. Have 16gig RAM.
Normal usage of Hearthstone is leaving me 11.89 - 12.56 gig ram. This is normal usage…regardless how many matches I play.
Problem: Yesterday when I logged in and started match with 12.89 RAM and immediately the RAM dropped to 8.98 RAM.
Other times the RAM would drop to 9.98 after three matches. I understand that some games need to store cache and other stuff over time during the game. But not to this level for Hearthstone. This is only happening with Hearthstone. I don’t run other software during Hearthstone as I listen to news while I play. This Macbookpro doesn’t have any significant applications as I just do internet and hearthstone on this. I’ve been testing this for over a month to see if it is only limited to hearthstone and it is. This problem only started about two months ago and I have a program running to catch what is using the RAM. Every time it has been Hearthstone that has dropped the RAM from over 11Gigs free to 9.98 or 8.98 Gigs Free. Please advise.
Thanks.

OrcanMutt,

Typically when I see that kind of problem it’s due to deck tracking software or some third party conflict with security or something like that. Do you use Innkeeper/Hearthstone Deck Tracker/etc? If so, can you uninstall those and see if that helps? If it does, you can try reinstalling them after.

Drakuloth,
Nope do not have any third party stuff for Hearthstone because two years ago I tried them and they kept crashing the Mac. So I just have Battlenet.app and the Hearthstone game and its been this way ever since. The only third party stuff I have is Brave Browser. But I’ve tested this issue with Brave Browser active and non-active. Still the same. The only thing I’ve not done with Brave Browser is uninstall but I don’t see how that would affect Hearthstone as I’m not using any of the browser software accelerators that is usually an option to select in the Battlenet APP? It shouldn’t. But is it possible to still use the browser assistance if the option is not selected? As Brave Browser is not showing up as using the RAM? I could move the default to Safari on the Mac for a while to see if that makes a difference? I’ll give this a shot and will write up any differences on Friday.

Hey there OrcanMutt,

It’s unlikely the browser is causing issues if it’s not active. It’s also possible there’s a bug with the drivers in that older build of Mac OS, though I’m not currently aware of any. Do you have the same problem on the latest build of catalina if you update your mac?

There were no differences with the browsers. This Mac is old enough that it cannot update to Catalina. Its a 2011. The only ones I think that can update to Catalina are 2012 or 2014 and later? Unsure. Anything earlier cannot be updated to Catalina…Uncertain of the year. But that’s the situation. I’m stuck with High Sierra because Catalina requires metal ability chipsets.

OrcanMutt,

Got you, that makes sense. Well for similar effect, we can re-combo-update back to 10.13.6. Doing this reinstalls your graphics drivers.

If this doesn’t work, we might be looking at something like an engine bug or a hardware issue. I haven’t heard any other reports from High Sierra users yet. Reinstalling the OS from scratch would rule out anything other than hardware or a bug, though. If reinstalling it works, there may have been some variable installed to one of your folders that might have caused the problem. If not, there’s not much we can do here in tech because hardware issues would be something you need to talk to Apple about, and the bug report forums are where the quality assurance teams take this kind of report. You can click here to go there if you’d like to report it as a bug: #bug-report