No sound on Hearthstone running Apple Studio M1 on MacOS

No sound on Hearthstone running Apple Studio M1 on macOS Monterey. Sound is working everywhere except Hearthstone.

Steps taken to troubleshoot and restore sound. → Preferences → Game Settings → Hearthstone → Reset In-Game Options
Mac OS → System Preferences → Sound → Device for sound output is set to my monitor. Name LG ULTRAWIDE, Type HDMI
Removed Hearthstone and installed Hearthstone
Removed Hearthstone, Removed Rebooted. Installed and installed Hearthstone.

Hearthstone since patch 24.0.3
Mac OS Monterey 12.5.1

What are the next steps to try to restore audio on Hearthstone in Apple M1 Studio?

Edit: Solution
Problem solved after updating to Mac OS Monterey 12.6

Same exact issue (no Hearthstone sound at all, Mac Mini M1, but I am running Monterey 12.6 which fixed the OP’s issue).

I’ve already attempted:

  • Ensuring in-game audio settings are correct (e.g. volumes turned up)
  • Restarted Hearthstone and BattleNet multiple times
  • Disconnected all 3.5mm/Thunderbolt/USB devices and tried using different audio outputs on the Mac (e.g. built-in speakers, etc.)
  • Tried scanning and repairing the Hearthstone app from within the BattleNet app
  • BattleNet Preferences → Game Settings → Hearthstone → Reset In-Game Options
  • Restarted computer
  • Saw a similar issue on another thread/forum where setting up an aggregate audio device in the MIDI Audio Setup worked - tried this, no change

All other volumes/apps on the computer are working completely normally.

I lost sound after recovering it post patching Mac OS X 12.6

Audio for everything except Hearthstone is working as expected.

I had exactly the same problem and finally figured out that it’s caused by audio plugins.

Microsoft Teams installed an audio plugin silently which blocks the audio from all the games. Delete any driver under /Library/Audio/Plug-Ins/HAL and sound comes back after reboot.

1 Like

Can confirm, I was having the same problem and this fixed it immediately. Thank you so much for finding this solution!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.