Hearthstone unable to load past the tavern doors

I’m playing on a 2012 macbook pro updated to Catalina.

Ever since yesterday’s update I haven’t been able to get the game to load past the initial start up. It opens the hearthstone window, then just stays on the part of the loading process that just has the closed tavern doors with the glowing rune (which is still glowing/loading) - Nothing is frozen and the mouse has swapped to the hearthstone glove, so I think it just doesn’t know how to get past the loading step?

Has anyone else experienced this? So far I’ve tried re-patching/repairing and completely uninstalling then reinstalling the game… but nothing helped.

Hey there,
got the same problem.

First i had the problem before i even updated to a Catalina, but it startet 3 days ago, so far i tried, repair, reinstall, update the mac then i updated to Catalina. Still the same problem.

maybe we can stay in touch until one of us finds a fix…

I use a macbook 2013 pro…

Any updates here?

I am also having this issue (2019 Macbook Pro, Catalina), and I feel like I’ve tried everything–and I mean EVERYTHING. Still haven’t been able to log in at all, in any region, or on any device, for over a week now.

I have a support ticket open, but nothing so far has worked.

Hi you two!

I haven’t had much luck, the problem is still present even after the buffs/nerfs and the patch to fix the store bug.

Strangely enough I have had the game start up past a loading screen a few times… but after like >30-45 mins of loading. And only a few times, most times it just doesn’t load.

Have either of you tried just letting the game load in the background? It’s certainly not a fix since most people play for the quick games… but maybe if you really want to play that will help?

Just got off the phone with Blizzard support, and, while we weren’t able to fix the problem, we found a pretty promising lead.

I am having this issue with several different games (Hearthstone, MTG: Arena, and Faeria). The common denominator is that these are all games made in Unity. I’m also seeing lots of errors involving “UnityPlayer.dylib”

So I was wondering whether either of you play other Unity-based games, and if you do, whether you are able to launch them. You can Google a list of Unity-based games if you want to test it out.