Game freezes when trying to open a pack

i haven’t played in a while.
i get this “welcome back free bundle”
so i open the game to open the pack and maybe play a bit.

Every time i pick up a pack with my cursor it disappears when i try to place it in the middle.
And everything in the game becomes unresponsive, except the game options button on the bottom right.

So i go to options and exit the game.
But it is happening every time, i can’t play at all.


Also, me and my friend cannot create any decks.
When clicking on “Choose” on a hero, nothing happens. Takes us back to our collection.

We also cannot access the shop.


I’m experiencing the same issue with pack opening. I can go to the game menu, but even there, the quit button is unresponsive for a minute (before the game finally closes).

I basically have the exact same problem, came back to get the free packs and play a little and every pack I try to open freezes the game.

Same problem. I can open one pack, but the moment I try to open another the game freezes and I lose the pack.

1 Like

same issue, rather annoying

same issue, rather annoying

same problem. have tried a fresh install on pc and mobile. it happens on both apps.

Hello any news on this? I have the same problem, also if you back out and try to play any game mode it just disconnects you and says that you’re not connected to the internet. The way to fix is to exit the game and relaunch.

fixed now for me
/ten chars

Just now after the release of March of the Lich King I’m trying to open Standard packs and I’m having a similar issue. When I try to open a pack, the 5 card backs are there, but they are unresponsive to clicking. The game itself isn’t quite frozen as I can still hit ESC and the menu pops up, but the cards cannot be interacted with. I tried restarting and it didn’t help either. What do I do?

they are disabled right now , so just wait


Ohhh I see. Thanks for the reply!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.