Diamond Y’shaarj portrait bug not received

Weeks ago maybe months ago, the Y’shaarj Limited time quest line appeared in mercenaries. Where are you complete 10 quests to earn lots of rewards including the diamond portrait of Said character. By the time I reached the ninth task some things look a little off. And that is why I discovered that the ninth quest was bugged and hearthstone did not correct the error in time. And now they owe me either the diamond portrait of Said character itself or they need to change the requirements to obtain said portrait to acquired from packs. Ever since that bug, I have been very angry at Blizzard eagerly waiting for them to pay where it is due. I hope they better pay soon or at least make it easier to obtain. Has anyone else been faced with this exact same issue?

This is all well and good, but why are you telling us?

We can’t help you and blizzard only reads the forums to ban people.

You should work with CS not us.

What is CS? I have tried but they were of no help they always tell me to post on forums.

Customer Service is the only folks who can help with your issue. If you’ve already tried, then there’s nothing to be done. Forums are useless for actually resolving your issues.

Customer support. Tried that did not work. This way the dev team can see my issue and fix it ASAP.

The Y’Shaarj event lasted from June 7 until June 21.

Task 9 was first available on the fifth day of the event (June 11) , which was when the bug was discovered.

The bug was hotfixed on June 13:

That was just over a week before the event ended.

1 Like

But every time I post my issue about the quest line bug. They cannot fix it. The least they can do is compensate me with this portrait or at the very least, change the requirements of the said portrait to acquired from packs. Also, I got the update. But it did not change the quest line quest#9 in time for me. So now they must pay.

That’s not how this works. You had a limited time to complete the event and the bug was fixed before the end of the event.

The devs don’t read these forums, but even if they did you won’t get any support for your case because you failed to complete the event in the allotted time.

ok. but once patch 23.4 went live, the bug was still there it said “Complete heroic Taran Zhu with _______ in Darkshore”. the word Darkshore is the bug. It should have been “The Sunken City”. But unfortunately, the bug did not fix in time. so now they have to compensate because i am not satisfied until everything of mine is right. this is only one of 4 issues. wanna know what the other 3 are?



No, the bug was that the quest originally could not be completed in any bounty.

After the June 13 hotfix, you could complete the quest by running heroic Taran Zhu.

You chose not to do that.

The incorrect wording in the quest text wasn’t the bug.

1 Like

I did run the bounty after the patch would live but it did not get completed after the run was over. So this issue was not about me it was about the bug not getting fixed on time. I tried multiple strategies including running said bounty after the patch went live. But it still did not complete the challenge