Dalaran Heist - Bug Thread


#1

So I noticed there was no general thread to add bug posts onto.
So here it is, if anyone needs it.
One bug I remember noticing was that Murrgatha (agatha themed murlock treasure unit) didn’t lock the enemy’s crystals like it was meant to or at least didn’t display that properly.
The second one was that Genn Graymane (again the spelling might be wrong here) didn’t apply his start of the game buff to my hero’s ability. And before you ask, I wasn’t using the treasure that changes the power to one of the lich king ones.


#2

Can you post the complete decklist of the deck you had when you noticed this?
(Remember that Genn’s start-of-game effect only applies if there are no odd-cost cards in your deck)


#3

One I just encountered is a combination of spells that doesn’t equate to what you’d think it would:
During a friendly encounter I played “Tell a Story” (+2/+2 to a minion) on my Zilliax.
Then I played “The Gang’s All Here!” (Add 3 copies of the card to my deck) on the same Zilliax.
Then I played “You’re All Fired!” (Remove all friendly minions from your deck).
Got into the next encounter and all my Zilliax were just the normal 3/2 instead of 5/4. Not sure if this is intended, but it doesn’t seem like it should be. If I use strategy in the friendly encounter, I should be rewarded for it, yeah? :stuck_out_tongue:


#4

In the Friendly Encounter, the card “The Gang’s All Here!” actually has this card text:

“Choose a friendly minion. Add three new copies of it to your Adventure Deck.” (emphasis mine)

So yeah, this is defintiely intended. A new Ziliax is not the same as the buffed Ziliax that you ended up discarding from your deck.


#5

observed today.

If dopplegangster is given buffs via InnKeeper, the cloned dopplegangsters do not get that buff when it is played


#6

Hi! So I ran into a, well, a bug or a technical issue of some sort. While playing The Violet Hold run with Rakanishu, I got a Shifting Scroll which turned into an Effigy, which I played. My minion died, and a Arch-Villain Rafaam was summoned. The AI still had a minion (10/11 custom beast) that could attack but the game or the AI kind of froze, with the Shifting Scroll card stuck on the left side of the board. I can still spectate cards etc.

So, I can basically still interact with everything in the game, but the AI turn won’t end and the Shifting Scroll won’t stop displaying.

I was able to reconnect to the same game after closing the Hearthstone client, also I am able to continue my run!

TLDR: Game/AI froze (at AI turn) because of an Shifting Scroll/Effigy interaction.


#7

Dadwave and Headrama: Thanks for the reports, but both issues are known already.

See Known Issues List 2019 - Updated May 22nd


#8

I cannot progress past the play screen in. Normal mode. My hero portrait is empty and I can click play but nothing happens. The game doesn’t lock here - I can still hit the back button - it just won’t progress. So this run is locked here and I can not reset since I can’t get the game to load in order to do so. Heroic mode is still working as intended. However, I can’t play the new content in heroic mode because I have to unlock it by beating it in normal first. Preformatted text


#9

There is a bug with the rogue card “unidentified contract”. When you reduce the cards cost at Bobs tavern it will go back to being 6 mana when it gains one of the bonuses while in your hand.


#10

So it is intended? I did the same with Swamp King Dread and with the “Tell a Story” (+2/+2 to a minion) it became 11/11. The I picked “The Gang’s All Here!” (Add 3 copies of the card to my deck) so 3 more Swamp King’s Dread went in to my deck. In the animation of putting the 3 cards in my deck on the right, the 3 Swamp King’s had the 11/11 stat’s. But when I Started a new game they were back to the 9/9. The animation with putting the 3 cards should be changed if the way it works, is intended.


#11

Yes, it is intended. That is why the card text on “The Gang’s All Heree!” does not read “(…). Add three copies (…)”, but “(…). Add three new copies (…)”.

Correct. This issue is already included in the list of known issues.


#13

The same has happened to me, however, it was in heroic in my case. I tried to login from PC and mobile but it didnt work on either of them. Its really bad that i am unable to play heroic , I suggest a hotfix as it affects the gameplay quite much.


#14

Playing against sky captain smiggs, he summons a ticket scalper on an empty board. I have a screenshot ( why won’t you let me post links. https:SlashSlashibb.coSlashMMfjJNV) which shows the minion somehow had the rush tag and ability. How, why, what? There are no aura effects in play.

He played captain hooktusk the turn before; that could be relevant. It was not able to summon 3 pirates because of the board space limit


#16

Stuck in Dalaran Heist Heroic mode in endless fights without filling the deck with cards from bundles.
each preview just keep displaying the Marei Loom profile and the actual fight takes place with some of the various bosses we can encounter during the run.
All of that result in a loop I can’t even end by conceding or letting myself lose against a boss


#17

Definitely relevant as I have seen other similar reports that all also had Hooktusk played on a full board prior.
It appears that Hooktusk is programmed to first give the selected pirates Rush, then summon them - and when there is no boardspace the summoning fails but the Rush tag sticks.


#18

I have the same problem with heroic that I am stuck in a loop. I tried to reinststall the game but it did nor work.


#19

I don’t know if that is intended but I encountered the first boss of the third chapter on heroic mode twice in a row. I don’t have screenshots because I didn’t expect the (deal 1 damage/ combo deal 3 damage) boss to reappear for the second fight :confused:

Also: Jepetto Joybuzz the final (heroic) boss seems unbeatable without the (half the cost) robes in combination with huge minions. I was able to beat him twice with the robes on heroic and lost without the robes about 4 times against him now. Can’t call that a bug but its worth mentioning.


#20

So the bugs with final boss in Heroic difficulty:

  • Hero ability ignores buying 0 cost cards(coin for example) and proceeds to buy the 2nd card, while it clearly should only apply to 1st card played.

  • When plays card that gains +2 damage when opponent plays spell, if that minion is stolen via Sylvanas and a spell played after that, it returns back to Boss’ board, which frankly makes 0 sense, cause you own that minion now.

  • The purchasing of the first card played doesn’t buy default card played but a fully buffed card (if buffs were applied from seeds or passives), which is the opposite when a player plays a card that copies or steals card from Boss.


#21

I assume that this is about the “Gallywix” encounter.
When this happened, did you play a normal Coin, or “Gallywix’s Coin” (a green version of the normal coin; see https://hearthstone.gamepedia.com/Gallywix%27s_Coin)? Note that the latter explicitly has on its card that text it doesn’t trigger Gallywix.

I don’t understand this description. It would help if you know the exact names of the cards involved, or if you have a screenshot, or a link to the game on hsreplay.net.
In general, once Sylvanas steals a minion that minion gets a new owner. If then that minion is returned to hand, it should go to the hand of that new owner.
If you saw a minion get stolen by Sylvanas and then return to the hand of the original owner, then that needs to be further investigated.

I assume this is once more Gallywix. He copies your card as you play it, so the card is copied from one hand to another. Moving cards hand to hand will not remove buffs or debuffs. (This was changed about a year ago, the rules were then simplified so that buffs and debuffs are always kept except when a card is moved or copied in “reverse” direction: graveyard --> board --> hand --> deck).
What should happen when a player copies or steals from a boss depends on which card is used for that stealing. But since you didn’t specificy this, I do not know whether or not what you saw would be a bug.


#22

When you reduce the cost of the new rogue assassination spell ~unidentified contract~ (on my run was the reduce by 3) on bob encounter, it only reduce the original copy. When you draw it and the card transform, it come backs to the original value (6).