22.2 Known Issues

not sure how valuable this info is, but not all of my 1k portraits are missing… my portraits earned before 2020 are showing just fine, just not ones earned after that

1 Like

Blizzard has been doing business with Google for a long time now and yet somehow the length of time it takes to roll out any updates has gotten worse.

1 Like

5:10pm PST and still no update for Chromebook users :frowning:

Have they ever compensated for downtime before?? I was locked out of Mercenaries for the first week it was launched and other times missed out on Daily Quests because of Blizzard errors and the thought of compensation was basically laughed at by the support member I spoke to.

We’re these issues that hit a small group of players specifically? This problem looks like it has wiped out an entire platform’s worth of users.

try it now someone said the update can be downloaded now

if it doesnt work someone else said its possible to do it through the amazon store

I’ve experienced an issue twice in a row in Casual mode. I played Kazakus, Golem Shaper, created a Golem, and then on the following turn, played a Brilliant Macaw. It copied Kazakus’ ability, but did not create a Golem. In the follow game, I played Kazakus on 4, then two turns later played Brilliant Macaw. Again, it copied Kazakus’ ability, but did not create a Golem. In both cases, I ensured that nothing was increasing or decreasing the cost of spells in my deck. I had no 4 cost either time.


bg skin disappeared from the store despite having a release date of 01/31 and 02/18

“In the meantime, you can restart your client to remove the Mercenary you don’t own from your Training Grounds slot and put a proper selection in there.”

I’ve restarted and reopened multiple times on both mobile and PC, and still can’t access. Is there another workaround?

Edit: restarting the client still doesn’t work, at least don’t say it works just to get our hopes up…


That version’s messed up too, it says I don’t own it. It sends me back to the store page, even after a reinstall.

After 22.2 update, I could get into the home screen except everything was running at 10 fps and I can’t click anthing. The shop icon, gamemodes icon, and tavern pass icon don’t show up either. (My pc is plenty capable and has been running hearthstone for a long time now)

Done about everything I could on my end to resolve it but nothing is working.

Some help would be appreciated

Me too- please fix this!

Duels achievements for the new characters aren’t tracking. I finished a 4-3 run with Vanndar but his achievement progress remains at 0.


I hope they fix this soon, I can’t play duels at all. Totally freezes once i press resume.


I’m also locked out of Mercernaries training grounds, because I used a Merc that I don’t own without realizing. I cannot open it to remove the Merc neither on PC nor iPhone.


In my journal, it says I have not completed Rokara’s Mercenary single player story but I had several months ago. I have the crown over the character in solo adventures

I played my Rustwix Phylactery deck in wild, and long story short, deathrattles dont trigger. Is it new bug from patch or old? I played 2 phylacterys with 3 mana tamsin on board, both against real opponent in casual mode and against AI, if it is important at all.


Same it’s really frustrating mine was with the other new hero.

Yeah same with me except for with Vanndar. Has anyone completed a run with the new heroes and NOT been locked out of duels?

Strange that a game bug that absolutely locks you out of playing a mode has not been fixed. This is incompetency at its finest. Wanted to play duels in the new patch. since apparently I had a run going I have to press resume. It locks my game there nothing I can do but restart.