Unable to continue S3 quest line

Wouldn’t be launch day without something screwing up…


Teleport to another town and then back using the map screen not your teleporter

1 Like

Teleport to another town and then back and you can click it

can confirm, teleporting to a town outside the hub and back in seems to fix the issue

1 Like

Disabled the cross play and worked. PC

i have the same issue. relogged twice and it still wont work.

good start … like they didnt even playtest at all.

im not even surprised at this point. just typical blizzard ridiculousness

1 Like

I can confirm it is NOT only effecting people on local co-op. I was playing console alone and it was clickable, switched to PC and still not clickable. I have never played console co-op ever. They should have pushed back the season until it was fixed. This is a bad look.


Never start season on launch day.

they had one job… literally one job… that the season mechanics work… now im stuck behind a wall waiting for a fix … just like last season everytime yall fixed something yall needed a hotfix to make it work… along with disabling cross play on a side bug which snowballed to another hot fix…
look i get it but for the money we all shelled out and continue to do, do they even test this at all?
and im on PC master race not console or co-op and its not working

Well that would cost money. Why not just have the players do it for free? We’re the beta testers… get used to it.

i find it highly sus that all the streamers are able to do it… hmmmmmmmm sus


id understand obscure weird bugs. but in plain sight so early in the season quest… that’s a whole new level of incompetence. they didnt try it at all.

i see ppl messing around the brazier every one of them has the same issue kekw

1 Like

Disabling Cross-Network Play + Cross-Network Communications and completely exiting the game like three times did it for me. Not a solution, just a band aid to get passed it I suppose. Thought I’d share.

Yep. I just exited out the game.

Disabling cross-play worked for me on PC

I had to combine the solutions to get it to work. I went to another town, exited the game, exited the client (just to be sure), logged back in, tp’d back and was finally able to access it. I also disabled cross play.

I was stuck as well on PC and tried relogging, teleporting, disabling cross play… nothing worked… what worked was starting chapter 2 of the season.

PS5, disabling cross play allowed it to click. was able to move past this

relogging didnt work, town and back didnt work, full reboot didnt work.

disabling cross-play and cross-play coms did work.

100% solution here, go to kyovashad, do the blacksmith quest, then go back to the brasier.