Unable to continue S3 quest line

Tried relogging, does not fix it.

Unable to Upgrade the Seneschal using the Brazier in the GateHall.

The thing is not clickable.

19 Likes

Same… why they do this. Wudijo was able to do it

completely exiting the game and relaunching fixes this.

Rebooting entirely made no difference here

1 Like

Didn’t work for me. Why

1 Like

No patch realm #20characters

tried relogging and restarting game nothing here

WHY LAUNCH WITH KNOWN BUGS, quick google tells me dont do co-op as it locks you out of the questline…im solo and locked out, they aint patching this for a week. IM ON PC FFS We would like to let players know that there is a quest currently in Season 3 titled ‘Drums of the Vault” that is leading to a progression blocker for players on local co-op. We are working on a fix for this and plan to have this out later this week. We will update players once this has been addressed.

A workaround for this is to not play this quest via local co-op on consoles until the fix has been released.

2 Likes

It does not stop baiting people.

Same cant click the Brazier

1 Like

Yeah same… relogging doesn’t fix it. GG

1 Like

The team is aware of this one and are investigating currently

9 Likes

To late, Wudjo is already way ahead cause of this.

Reset ladder is the only option for fair sport.

5 Likes

There is no ladder currently

5 Likes

was playing with cross play disabled. unabling cross play and relogging solved it for me

3 Likes

Add me to the list. PC and playing solo, unable to interact with the quest objective.

1 Like

I disabled cross play and it now works (PC).

7 Likes

The Gauntlet/Ladder content won’t be here until mid-season, just like AoZ.

2 Likes

That worked for me too! On PS5. Thanks!

Just a heads up for future viewers, turning off crossplay is not a 100% fix. It’s still not clickable for me (PC) after turning it off.

Edit: Exiting the game a few times seemed to have worked. Likely just took a bit for the process to update.

1 Like