Prism device removal detected

I get this crash every so often. Seems GPU related as my computer gets hotter. My GPU is not suitable for the game but it runs until it crahes…

GPU: Intel UHD 620
|Processor|Intel(R) Core™ i7-8550U CPU @ 1.80GHz 1.99 GHz|
|Installed RAM|16.0 GB (15.9 GB usable)|
|System type|64-bit operating system, x64-based processor|

|Edition|Windows 10 Pro|
|OS build|19045.2846|
|Experience|Windows Feature Experience Pack 120.2212.4190.0|


Just got this one for the first time, too. I play on an ultrabook with MX350. The game seems to be running fine overall.

10.06.2023: Just got it for the second time. So at least it doesn’t seem to happen very often. And it seems it takes about 4 hours of playing at a time to get it.

CPU: Intel Core i7-10510U
RAM: 16 Gb
GPU: Nvidia GeForce MX350

1 Like

Yep, also getting this. Been having driver timeout issues constantly since the beginning of the early release - only blizzard games are causing this. High end PC as well.

EDIT 17/06/2023

Blizzard finally came back with some realistic advice, I’ve uninstalled a few things and updated some others and the crashes are less and less frequent. Here’s the full reply from Blizzard support:

I hope you’re doing well.

First of all, sorry for the response time, we’re receiving a lot of tickets at the moment, we’re trying our best to answer everyone as soon as possible.

Thank you for taking the time to recontact us regarding a crashes issue on Diablo 4. I know this situation can be frustrating, it’s never fun not being able to enjoy a game. Don’t worry, we’ll try to solve this together. :slight_smile:

First of all, we received some similar reports but nothing has been confirmed so far, we’re still collecting informations.

There’s a few manipulations to perform to try solving this problem or at least, reduce the frequency of crashes.

Please make sure that everything is up-to-date on your computer, especially the bios :
battle (dotnet)/support/article/31024

In some cases, disabling the XMP solved the problem.

Your graphic drivers might be partially corrupted. You should uninstall them using the DDU program before performing a clean install.

It could be caused by another program. To rule out most of them, please perform the steps of this following article :
battle (dotnet)/support/article/23848

Some programs can still cause problems, even when deactivated. To be safe, you should temporarily uninstall :

  • Armory crate
  • asus AI suite
  • asus rog gamefirst (rog live)
  • aura lighting sync

There’s also the Geforce Experience sharing/shadowplay to disable, same goes for the Windows DVR/gamebar and the Discord overlay.

Ingame, lower the game settings and set a fps cap (60 for example). Also uninstall the HD assets. Try playing in a windowed mode and at a lower resolution.

You should also check if there’s any overheating issue :
battle (dotnet)/support/article/31363

If you don’t see any improvement, we’ll need an updated version of your diagnostic files for more troubleshooting :
battle (dotnet)/support/article/12988

Hoping that these manipulations will be helpful.

Thank you for your great patience. I wish you the best. And enjoy your week-end ! :slight_smile:

Customer Support

Can’t post links (even to blizzards own website…) so find and replace (dotnet) with .net and you can follow them

1 Like

i just got this same crash and its happened twice now. very soon after starting. any help would be great

1 Like

The same Crash happens to me all the time - always a few minutes into the game. Doesn’t matter if a cut-scene is playing or the game is running.
“Prism device removal detected”

edit: Still no fix two days later - people paid 80€ and more for this and there is no response whatsoever?


Same Problem for me unfortunately. The last 2 days no crash at all. Today 4 times with the “device removal detected” message. Game is running smoothly until it crashes


Same here! 12gb RAM i7-Core 8550U- Intel UHD620 which ran Diablo 3 Perfectly and ran Diablo 4 also perfectly for a while! something was changed in one of the updates as i played for hours, even leveled character to Level 10, after that update (the update before today’s update) no more… Fenris errors until today… but with today’s update no more Fenris error and game is starting up more smoothly but long behold a new error:

Prism Error Device Removal (Error #1).

Considering it is 199EUR for the game and that the requirements did not specify that iGPU’s are not supported anymore (as they worked fine with Diablo 3 and Diablo 4 worked fine with the inital tests until fenris error started).

This needs to be fixed as there is no reason that for 199EUR per person Blizzard cannot run a version of the game that will run on iGPU’s and/ or provide a parametered version that allows it to run on iGPU’s!

People who play Diablo have done so for many years! would be ashame to lose out on so many fans just because the game was developped to be incompatible with iGPU’s (not even older machines!!!)

Asking for friends



same problem here!! any update of how we can solve that?


same here…
Ryzen 7 16Gb RX 6650 XT

1 Like

Just had this issue. Was kicked out while teleporting to town. I’m running an AMD Ryzen 5 2600 Six-Core as my Processor, with 16GB of RAM, with an NVIDIA GeForce GTX 970 for graphics. I definitely thought I could manage with my set up.

1 Like

Same issue here. Radeon RX 5700 XT.


Same issue. Randomly crashes while running well.

1 Like

Same issue. But older computer: intel i5-3330, Nvidia Quadro K620, 16GB of ram
I knew there would be lag and some bugs coming with an old computer like that, but the game was running pretty decently. First time seeing this error.

Did not have any trouble during the beta in May, though.

1 Like

Same issue here. Seems to be temperature related as well. If I let the laptop cool down for say 5 minutes or so. I get to play longer… sigh. otherwise crashes as FPS goes up. I am also using < min req graphics card (intel UHD graphics 10th gen)

1 Like

Is getting very annoying crashing very 1-2 hours with this bug - looking for a fix action


I dont think it’s heat related actually. I’ve gotten alot of crashes now where my computer is not hot. Seems like maybe something else is causing the crashes now because I get crashed more after this patch, like when i open my map and my computer is cool…


crash! crash! crash! same problem as above

1 Like

Same problem. Same message. Please help, the game is unplayable as it stands. Well, I can’t even get to the point of moving the character around, although I did get to make one.

1 Like

I just got it too; weird. I was just teleporting back to town. After the crash though, the game needed an update, not sure if that has anything to do with it. Loving the game though, I think this may be the best Diablo of all time.


I keep getting this error too, never had this issue with the Beta or Server slame, just started with this version

1 Like