Item tooltip flashes

It is so annoying bug ,I play the game only if i forget about it. None of the solutions work for me.

pain :

1 Like

Same issue here on PC, started with patch 1.1.1.
Didn’t have this issue before.

this worked for me as well. Thanks for figuring out this workaround!

1 Like

This seems to be tied to interaction between others players walking around taking priority over the item hover selection. To test I turned off cross network play and went to town and there were no players walking around and I had zero issues until another random player showed up and went to sell at the same vendor and the flicker happened when he ran up and again when he ran away.

I have not yet tested the workarounds or solutions other players have posted but this at least seems to be the reason this is happening once the bug is introduced, I suspect this is likely a graphics driver update interaction and a stored value that is then cleared with turning on and off this tooltip setting and saving in between.

Edit: workarounds posted here do no work form me, performed a clean driver installation of nvidia driver ver 527.56 and went into in game settings > Graphics > clicked “Reset to Defaults” button on bottom of the screen. This has not fully resolved the issue but at least drastically reduced it’s occurrence to the point where I can no longer reproduce reliably, however it does still happen. (Clean re-installation of driver alone did not fix the issue)

My list of default graphics as this will be different for each player based on PC specs.
Display : Windowed full screen
Sharpen Image : 6
Font Scale: Medium
Cursor Scale: Small
HDR: yes
Vertical Sync: Yes
Limit Cutscene FPS: Yes
Lock cursor: No
Color Blind Filter: Off
Resolution Percentage: 100%
NVIDIA DLSS: Off (this was on before)
Frame Generation: No (disabled by DLSS being toggled off)
Max Foreground FPS : 150
Max Background FPS: 8
NVIDIA Reflect Low Latency: Enabled
Quality Preset: High
Texture Quality: High
Anisotropic Filtering: 16x
Shadow Quality: High
Dynamic Shadows: Yes
Soft Shadows: Yes
Shader Quality: High
SSAO Quality: Medium
remaining item quality levels are on highest setting.
Distortion: Yes
Low FS: No

1 Like

Glad it worked for you until this gets fixed.

This appeared to work at first but after a few minutes and more compares it came back.

1 Like

Really irritating. Only happened since 1.1.1. NOT fixed with any patches since then.

100% Agreed. This bug came to live literally same day when 1.1.1 applied, me and all my friends have noticed it during the game through the day. It is insanely annoying.

Same for me post patch.

Funny enough in my case this happens only with legendary gear not rare… Go figure.

1 Like

I also recently started experiencing this issue. It’s incredibly annoying, when trying to compare items. :man_facepalming:

Same issue here since patch 1.1.1, annoying, I cant compare items and yes, so far only legendaries or uniques.
BUT! After playing D4 i startet running a few rounds Warzone and the cursor startet flackering there as well! maybe only by accident but figure out!
So far, something did the patch 1.1.1 for sure.
No graphics scalling, no mouse issue, sync …

I get this too, alt tab in and out of the game - I find that fixes most UI bugs, including the one where dialogue isn’t skippable

same here, pretty annoying

Still broken with 1.1.2…

1 Like

Indeed, It’s pathetic. The build on release was much better at this point lmao.

I’m having the same issue, it is so enfuriating!!! I need time to look at my items and learn what I need, it’s hard with so many items and things to remember, and yet this annoying problem makes it harder to concentrate. Now I understand why people get so mad fast at this company!

Playing is supposed to be fun and we have to deal with dumb bugs …

I tried what is suggested in this topic and it didn’t work for me. I tried enabling 1 thing, then the other, then disabling both, then enabling both, always saving. The problem happened all the time, with legendary items, not yellows (I didn’t test uniques).


1 Like

Same for me.
It only happens when there are other players around.

Increased my ram from 8gigs to 24gigs today, problem stopped.

This issue has been driving me crazy since the patch & this sounds like a meme workaround answer but it worked.

I was coincidentally planning to upgrade my RAM this week anyways and the problem stopped when I upped it from 16 to 64. That sounds like an overkill, I know, but it’s weird that overkilling the system requirements is what fixes a glitch affecting so many people.

17 days and one patch later still not addressed, not a word on the issue, no hotfix. Such a clown developer. This is a new low for the gaming industry, completely unacceptable. HEY BLIZZARD ! HELLOOOOOOOOO ?

1 Like