Item tooltip flashes

I’ve had this issue from season start (I do not recall having this problem pre-season). After 1.1.1. it’s way worse than before :confused:

1 Like

Same issue here after the patch…

1 Like

Having the same issue. At first i thought it was stick drift on the controller. Unplugged and used mouse keyboard, same problem. This started after last patch 1.1.1.

This happens for me aswell, only started after 1.1.1, playing on PC.

1 Like

Thx, I just came here to report the same thing. So, add one more vote to the fact that this is a real issue, if there were any doubts.

1 Like

Same bug here. Gets really annoying when you are trying to compare items, and the tooltip disappears every second for 1 second

1 Like

Thought I had solved the problem by exiting/restarting certain apps. Upon TP to Kyovashad, problem resumed immediately. I exited everything again, no change to blinking. 1.1.1 is what started it for me as well. Moving away from players seems to help. Clearly a game issue.

To everyone who is not having this problem, good for you. To anyone who thinks that this problem is not wide spread because not everyone is having this issue, that’s not how any of this works.

Since it tends to stop when moving away from players, I’m going to wildly speculate without an ounce of real evidence that this is the beginning of what happens when they add too many stash tabs to the inventory system that some sophomore comp sci intern programmed for diablo 3. j/k not really.

+1 to this issue. PITA.

This fixxed my flash

1 Like

This started for me with this patch: HOTFIX 1 - August 9, 2023 - 1.1.1

Super annoying.

1 Like

I’m having the exact same issue and was before the patch too. I had a feeling it might be players moving behind the inventory screen, but it even does it when know one this there (I think, it’s hard to tell!) Super annoying!

I never saw it before 1.1.1, but its been happening here too ever since. Only seems to be legendaries though.

Glad it helped. Hope it works for others until it gets fixed. Pretty frustrating!

I am also constantly having this issue since 1.1.1

1 Like

Just confirming here that Malgeist’s suggestion to uncheck Advanced Tooltip Information worked, however, that makes working on your build a nightmare. I took note on PR083’s comment that player movement triggers the flickering. I tried to find a corner of Kyovshad with no one around but the snow particles were still causing the issue. Went up into the room and sat to the right of the wardrobe and zoomed in completely - flickering goes away and both Advanced Tooltip options are turned on.

Issue also only appeared for me after most recent patch.

1 Like

also happening to mee :confused:

Also experiencing this. Thanks for all you do Blizz.

Getting the same flicker when trying to view my gear stats…pretty frustrating when trying to see the stats. Please fix!

Still ongoing issue.

WHAT THE EF Blizzard!

1 Like

Worked for me thank u sir✌️