Im freaking getting tired of this mini disconnection ON TELEPORT

yea i feel like im robbed. Cant play for 3 weeks now. If only refund was possible

1 Like

i have the same issue

Please blizz for the love of Diablo fix these disconnects!

1 Like

Still a problem for me since 1.1.1

1 Like

This bug is about loading and disposing loaded resources on teleport.
Blizzard blames users network, but it has nothing to do with networking.
This happens only on teleport.
This is a 100% a university class code which they can not understand the base of the bug, and you can see this with many things they implemented in the game eg horse riding.
This is the situation you are facing here.
If there was a technical problem on our part, i would not be here trust me, i would fix it alone.
This is the 1st time i try to check if something is getting tracked in bugs and instead i see that they blame the users.
Again 1 high end pc is working, 2nd low end pc is getting disconnected ONLY on teleport, if you dont teleport you will never get disconnected.
This bug appeared to all users after 1.5month of release simuteanously.

I have not seen them blame this on the users at all. I have seen them suggesting the users check their systems first, which, while a default response, is not the same as placing blame. So lets clear that misconception up.

They of course are going to suggest steps for troubleshooting ANY problem and most of those steps are going to follow the same route.

We all know there are issues. And they may be working on the issues. But to tell us they are working on them is the same as admitting they know about them, and they don’t seem to want to accept a problem till they have it solved, then they will talk about it. And even then the information will be the bare minimum.

My biggest beef with Blizzard is NO COMMUNICATION.

They acknowledged a few times they are bad about it, BUT NEVER IMPROVE IT.

Campfire chats aren’t the answer.

They need to visit their community directly. And not on Twitter or Facebook. HERE. On the bloody official FORUM.

But no. Silence is preferred and/or tidbits of info on Twitter seems to be sufficient.

They won’t learn.

So in the mean time, you all get to be frustrated while having issues that you can’t seem to resolve. Its sucks.

And to further my point:

The lack of real communication. There was a hotfix for a specific bug with an item, but a vague mention of stability fixes.

1 Like

Good grief blizz I’m still having this issue everytime I teleport! FIX PLZ ffs!

I’m so frustrated! I just want to play without getting disconnected everytime I teleport!

3 months no disconnect issues, until 1.1.1 !!

A couple of people have had luck with discovering they had some computer performance problems.

One had adjusted their swap file, (for some reason they were using a HDD for it) changed to their SSD and it fixed the problem. Another had found they were somehow running on 8GB of memory instead of 16GB like they thought, they bought more memory, found out one of the 8GB modules had either not been fully seated or come out. Now their issues with teleport went way.

So it begs the question whether something changed with the patch that because some systems might not be performing as well, it apparently is causing a sort of mini time-out when you go to teleport.

So far tonight, I have not been able to replicate this, nor have I had this phenomenon happen to me yet.

But its at least worth looking into.

See if you can max out your performance, clean up files, shut down running programs, make sure your swap file is set optimally. (you can even try disabling it temporarily for a test, won’t hurt the system, but only if you have 20GB of RAM or more)

Back down the texture settings a tad, things like that. Disable cross play, turn off Nvidia reflex, cap the FPS a bit lower, etc.

Please post if some changes like these actually help you or anyone’s symptoms.

I tried the cross play thing, it didn’t seem to matter. How do I do the other stuff you mentioned?

Well, shutting down programs should be straight forward. Essentially close or exit any programs not required to play the game.

Things like:

  • Social media apps.
  • Browsers.
  • Chat programs.
  • Music players.
  • Downloaders.

You want to be running as little as needed.

Run a system disk cleanup. You can search the start menu for that one. It has a button near the bottom to clean system files for more thorough cleaning.

If you are not computer savvy, not going to point you into messing with your swap file. Chances are, its set correctly anyway.

Make sure the game is running from the fastest drive in your system. Preferably an NVME SSD. SATA based SSDs are much slower, HDDs are way slower, even in RAID setups for desktops.

For starters.

Good luck.

Yeah the only app I have running In the background is mobylitics, I did a disk clean a few days ago. I tried without mobylitics and it didn’t make a difference.

I had weird things happen with Mobylitics, I ended up uninstalling it completely. I just didn’t like how it was interacting with things.

What are your system specs:

  • CPU brand & model
  • RAM speed & amount
  • GPU brand & model
  • Windows installed
  • Type of drive Windows and D4 is installed on (same drive, different drives, nvme ssd, sata ssd, hdd)
  • Power supply brand and model/wattage
  • Laptop or Desktop
  • How you are connected to your internet

I’ll try it again, I tried it before and I still got dc’d everytime I teleported.

At exactly what point during the teleporting process does this happen? During the animation creating the “portal” where you are, during the splash screen, or after you arrive at the destination?

Why would all that matter if I was playing fine for 3 months though?

I have no idea. I’m literally trying to pin down a relation to the problem.

Obviously not everyone is having the same issue. lol

I hit teleport, it goes to a loading screen, then to a black screen, then it says my network got disconnected and it takes me to character creation screen.

Ok, so its timing out during the loading screen or splash screen between where you are and where you are going? Correct?

You never actually see the destination load? I’m assuming the loading screen shows up normally… Like it shows a scene sometimes, or your character sometimes, right?