Game hangs at loading after patch

try removing Dstorage.dll

3 Likes

Yo remove Dstorage.dll works

1 Like

What exactly is the purpose of that .dll besides the obvious name of “storage”?

I was able to play an hour of Helltides by logging to my Xbox. I had this same issue of getting stuck at the Blizzard screen when I was launching the game from Steam. It’s much more common with Steam. With Battle.net, this is the first time I have seen it since I bought the game from Battle.net

Edit: I’m able to login to Battle.net right after I logged out from my Xbox. As soon as I was able to enter the game via Battle.net, I immediately logged out and relaunch Battle.net and now it’s stuck at the Blizzard screen again lol.

Did they fix it ?

We have a long time , if i not able to play i bought the game for what ?

Give money Back to PC players if only console can play the game !!!

This the only solution that worked for me. Thank you!

1 Like

Dstorage.dll をRemoveまたはRenameすると言うヒントから、GURU3DでD4のDstorage.dllに問題があるというTopicを見つけました。

このフォーラムは直接URLを載せる事ができないので言葉だけの説明になってしまうのでわかりにくくてすみません。

つまりD4のDstorage.dll のバージョンが古いせいでバグってるせいみたいです。
D4のフォルダに入っている Dstorage.dll のバージョンは v1.0.2 ですが、
最新版は v1.2.2 なので、わたしはMicrosoftの公式の DirectStorage API Downloads サイトからそれをダウンロードして

dstorage.dll (v1.2.2)
dstoragecore.dll (v1.2.2)

上記に2つに入れ換えて問題無くゲームができるようになりました。
ただしこの方法は正式なものではないので個人のリスクで試してください。

------------------------------
Based on the hint to remove or rename Dstorage.dll, I found a topic that says there is a problem with D4’s Dstorage.dll in GURU3D.

(I’m sorry if this forum doesn’t allow you to post URLs directly, so the explanations are only in words, so I’m sorry if it’s hard to understand.)

In other words, it seems that the bug is caused by the old version of Dstorage.dll in D4.
The version of Dstorage.dll in the D4 folder is v1.0.2, but
The latest version is v1.2.2, so I downloaded it from Microsoft’s official DirectStorage API Downloads site.

dstorage.dll (v1.2.2)
dstoragecore.dll (v1.2.2)

After replacing the two above, I was able to play the game without any problems.
However, this method is not official, so try it at your own risk.

3 Likes

deleting dstorage.dll worked for me! Funny how the community found a fix way before an official one! GG

3 Likes

it is related to the speed of the nvme ssd drives as per my testing. copying to a non nvme ssd works like a charm. bump it for people to know the solution.

That’s because they don’t play their own game…

1 Like

Same Problem here. Graficcard is up to date. Game repaired… stil hang on the loading screen. Cant play the game.

Thats one of the worst patches ever…

Also worked for me. Thanks for the hint.

Very nice, Blizzard. Your incompetence is astounding !
Keep it up, you’re doing just fine !!

1 Like

How about instead of thanking us for our patience you just get your sh#% fixed.

2 Likes

dstorage.dll is probably the front end for DirectStorage. DirectStorage is a high speed file read API intended for modern games. It allows file I/O to be performed with significantly lower latency and CPU overhead.

I do not recommend people do this. As Diablo IV has some form of anti-cheat built in, this sort of change will be prone to running afoul of it as game program files would not match what is expected.

Additionally the reason the DLLs are deployed by the game and not as part of the OS is because the API might be subject to breaking changes. As a result a newer version of the DLL files might not be suitable to replace older ones.

Like wise deleting the dll might not be a good idea from this perspective as then an expected piece of program code is missing.

2 Likes

just patched this morning, trying to start my day with Diablo and Coffee… looks like it’s just gonna be coffee today.

2 Likes

去年の6月6日に起きたNVMeのSSDの問題がまた発生しましたね。
つまり開発陣はデグレードを引き起こしたと思います。
開発資材を正しく最新化できてないと思いましたね。
Blizzard社はいったいどんな管理をしているのか首をかしげます。

------------------------------

The NVMe SSD problem that occurred on June 6th last year has occurred again.
In other words, I think the development team caused the degradation.
I thought that the development materials were not properly updated.
I wonder what kind of management Blizzard is doing.

I have the issue on two different laptops. 1 Windows 10 and 1 Windows 11.
All after the patch.

Holy Crap, this issue is still happening today?! UNREAL

And you rly dont need an PTR??
There are so many bug… and you are not in the position to test it the way you need to.
Set an PTR…get the feedback… fix the bugs… Release it on live and all happy…

1 Like

I am also unable to get past login since the patch. I’ve tried the following:

  • Reboot
  • Scan and repair game files
  • Check for driver updates
  • Uninstall and reinstall
  • Run sfc /scannow
  • Uninstall, delete local D4 folders, reboot, then reinstall again

None of that has changed the behavior of the game. It will start, maybe get through a splash screen or two, then freeze (though audio sometimes continues for a bit) and Windows will come up with the dialog that says the game is unresponsive. At that point it will send the error to Microsoft and then close the program.

1 Like