Game freeze on Character Select

Got through the login queue
Game froze on character select before displaying any of my characters
No error message; just froze and stayed like that for over a minute before I alt-f4’d

Description of frozen screen since I can’t link to image showing it:

  • Grey top bar with the red PLAY button in the middle
  • Completely black background
  • Left side UI box with greyed out CREATE NEW CHARACTER button, an empty list, and red START GAME button
  • Right side UI box with a barbarian helmet icon at top, mid of it, the words ETERNAL REALM, and red buttons CHANGE WORLD TIER and DELETE CHARACTER
  • Red bell icon button at lower, right side of screen
  • At the lower middle of the screen, barely visible are the Zoom and Game Menu words, like there is an overlay over them.

Same here, game freeze right after login.


same here freeze and game crash!


same problem here, cant play since the recent update.

1 Like

same problem, it worked fine for me yesterday, only after today’s update it doesn’t work

Update: after 7 minute ± my charakters load back but game run in 10-20 fps but after alt + tab game is back on normal FPS

1 Like

Same for me, tried repairing game files, deleting localprefs.txt, nothing helped, have to alt + f4 the game and then kill it in task manager because it does not shut down.

1 Like

Same here game freezes after login

1 Like

Yeah… What is this? I got the same thing now.

1 Like

Same problem for me after update, worked fine before


I was just popping over to report this. same experience. Attempted to create a Necromancer. then exactly as OP described. Attempted to get into a pre existing character, Same result.

Hopefully there will be some proper wait screens and/or error messages when the game goes full release/gold/whatever it’s called these days.

Fun when it works though.


Same bug here. Will try to wait a longer time and see if it unlocks eventually


I have the exact same issue. It’s like the game freezes after you’ve logged in, and you’re stuck on character select without anything showing properly. The recent update seems to have made some kind of error.

I tried “scan and repair” - did nothing.

I tried to just wait it out (music still playing in background, so maybe its just 99% stuck). Took about 5 minutes, then it reconnected and i could log in to characters!

So, waiting it out seems to work. Even though its wierd :slight_smile:


same problem here, at least yesterday i was able to play after getting through the teriible queue times, but after the 2 updates/hotfixes today i freeze at character selection.
video card is Nvidia geforce GTX 1660 super
its not very fun after paying 100 euros for the game
also after alt+f4, the game audio still lingers for a couple minutes in the background, task manager shows that the game is closed but still thinks the game is running

Same here,
tried scan & repair too

Same issue here, Window mode makes my game freeze and black screen for at least ten mins after login. Please bring back full-screen mode.

1 Like

Same exact issue.
Scanning and repairing now.

First login - frame rate was very low.

  • Uninstalled AMD software and drivers and reinstalled drivers only

Second login - Issue seen above.

  • Alt-F4, music still playing.
  • D4 executable not found on task manager, using 6+gb ram.
  • Killed, Diablo 4 executable appears with same amount of RAM usage.
  • Killed Diablo 4 executable.

Third + Fourth login - Same as second.

  • Scanned files

Fifth Login - Same as second.

Same problem here

(isn’t it easier to just allow us to post images ?)

Same I had a small update 0.8.139858
was the only change from last night

Getting the same. it’s as if it loses connection or waiting for a reply when trying to pull the character list, and while it’s waiting it’s completely frozen, with no indication it has not crashed.

After 4 minutes it said it was reconnecting, and then it loaded my char list.

So what works for me with this problem:
Just wait patiently, even though it looks like it has frozen.


Same problem here. Also, as ThomasW mentioned, just waiting seems to work for some reason for me also. Eventually, it just loads in my character. (I only have one, currently).