FIX : Game won't open since patch

Since the patch, game wouldn’t open.
Event log :
The program Diablo IV.exe version stopped interacting with Windows and was closed.

Looking at the interwebs, everyone pointed to directStorage ( go to D4 folder, find dstorage.dll and dstoragecore.dll)

my dll were : v 1.0.2205.2402

renamed them to .dll.bak files

downloaded the latest packages

Cant post link Google " Microsoft.Direct3D.DirectStorage nuget"

Unzipped it,

went to native/bin/x64/

and copied the 2 dlls to my D4 folder.

Game now loads.

Question is:

Can we get an answer on if it is a correct fix, can this cause issues, etc?


Also another fix is to DNS flush your computer.
open up command promp
ipconfig /release
ipconfig /renew
ipconfig /flushdns


The same issue.
thanks for post- work for me

Thanks, this direct storage fix seems to have worked for me. At least I can log in, will see if I encounter other issues.

The DNS flush worked yesterday, but the game won’t start at all today, no matter what I do.

I think my issue is slightly different.
After I click ‘play’ from the launcher, I get the blizzard splash screen with some animation on it. This should normally then fade to black and continue with the loading process.

50% of the time now, the screen freezes (the subtle animations stop), and you get a blue spinner on your mouse icon.

50% of the time it works fine.

1 Like

That worked for me - thank you!

Well if you replace the two dll’s, with say version 1.2.2 from Microsoft, bnet/diablo 4 will ‘fix’ those back to the packaged version at some point.

Unfortunately to day i have the same issue so this works for 24 hours. something crazy

If you go check those files, you’ll see they reverted to the 1.0.2 version. Re-replace them with the downloaded version.

Alternatively, use the startup flag to disable ds:

1 Like