'You cannot equip more than one.....'

I created a Primal Ancient Squirts amulet using the new Kanai’s Cube feature and the game will not allow me to equip it. I get the ‘You cannot equip more than one of these items’ error message. This also occurred when I created a Primal Ancient Stone of Jordan ring. Several resets of the game did not resolve the issue. Is this a bug or a new limitation?


Not a Bug.

We have also added a Primal Item recipe to Kanai’s Cube, allowing you to upgrade any non-crafted legendary item to a Primal Item for 100 Primordial Ashes. Only one upgraded Primal Item may be worn at a time and upgraded Primal Items do not retain the properties of the Legendary Item that was used. New affixes are rolled for all upgraded Primal Items.


Would it really be that difficult to read the information provided before making false bug reports? Blizzard basically shoves the blog in to your face, it’s not like one can miss it.


Thanks so much, I did search for this issue in the forums before asking.

It’s a feature added with Patch 2.7.5, deployed Tuesday.

It’s posted in the Season 28 Preview Patch Notes, under Primordial Ashes Feature:

Always check the “front page news”.  

1 Like


Per some internet resources, the global literacy rate for all people aged 15 and above is 86.3% so there is a chance, a Blizzard chance, that some people can’t read or are under the age of 15. And both. And, with this being a Blizzard chance, it is guaranteed.

If they are making written posts in the forums, I don’t think it is too much to expect them to be able to read as well.


I truly Thank those that ‘offered’ assistance…for those of you that spend your lives making fun of others… It’s a shame that you have to make fun of or put down others to make yourselves feel better.


It’s a shame that so many players just don’t bother to do any research whatsoever, and even worse, decide to post it in a bug report forum rather than just ask a question on either the general discussion or new player forum.


Excuse us for having a life and not noticing them adding ridiculous problems like this to the game.


What problem?

Ethereals worked this way. Sanctified items worked this way. Why is everyone surprised when Primordial crafted items also work this way?

The patch notes say you can only use one at a time, and when you try to use more than one at a time, the game tells you that you can only wear one at a time.

When this happens, you should assume you are doing something wrong and then go read the instructions, not jump to the conclusion that the game is bugged and start making bogus bug reports.

No one here is making fun of anyone else. If something does not work like you think it should, then your first step should be to go do a quick search.


Kinda boring to be fair, its the send off season just let people go ham if they want to.


“If someone is having fun other than me that means the game is bad :rage:” - The 50 year old virgins in this forum.


And this is why I just stopped playing D3 just now. Crafted a second primal and got me to this post :). No point to continue, such a shame they limit it to one. See you all in D4 beta soon


Funny, same thing just happened to me, nearly just said screw it and quit.


just found this post after upgrading my ring. Should at least put a warning in the cube, never would’ve thought to check this. Ah well, was a fun season, cya in D4


Definitely a bug, they didn’t even hint at not being able to wear more than one on the recipe, not even a “this recipe is dangerous, proceed at your risk” or something of the likes, and then after I did it and broke my build, the message was so vague that I had to google it to understand what happened, and then I found this thread. Really frustrating, and also having to go outside the game to understand what’s happening is a bad design.


How can it be a bug, when it is stated clearly in the patch notes? Failure to read does not make it a bug.

  • Only one upgraded Primal Item may be worn at a time and upgraded Primal Items do not retain the properties of the Legendary Item that was used.
1 Like

I’ll rephrase it, “definitely something they should fix”.

A warning on the recipe would be great, or at the very least a better message after you did it so you don’t need to waste time searching for why it says that you can’t wear two of the same items when you don’t even have a bracer equipped.


Oh, I get Arafek’s point. Angelic Crucibles were seasonal thing only, and they disappeared afterwards, so one could easily say “read the patch notes”, and it would be fine.

Cube recipe #11 is, however, a permanent feature of the game. Yes, there is some warning in the patch notes, but I get why it is not enough. Imagine, a new player comes to play Diablo when there’s season 30 - there won’t be patch notes for Cube recipe #11 then.

I just checked Diablo Wiki (I mean, the official, run by Blizzard) and it still lists only 3 crafting materials:

and the Cube part

does not mention recipe #11.

Now, I think that a warning for this recipe in the official wiki would be enough (since it is a kind of a manual for the game, right?)