S29 Journey not updating/working

I started a new Crusader for season 29. I had issues logging in initially, and after restarting D3, was able to login and create my hero. Challenge rift worked just fine, and I was able to claim the cache. I started having the problem after doing things that I know are on the seasonal journey, and was not getting credit for them. I can pull up the journey, and it shows the usual list of things to do. After getting to lv 54 and doing a lot of the basic things, in chapter 1 for example, the journey is not updating. I restarted D3 and did a rift to try to trigger that completion, and it didn’t work. I restarted battle.net and my pc, and went and got a level up, and I’m still not getting credit for reaching lv 50. :frowning: I would like to be able to earn the pet and portrait, at least. I can handle not getting haedrig’s gift. The game has been loading slower than usual. It lags longer than normal on retrieving hero list, and also when first getting into game. I tried a new character, and it’s still not working.


I’ve had the exact same issue! I’ve completed all the most wanted objectives for chapter 3 and done everything for chapter 1 and two and I’ve seen the award pop up on screen but credit NOT given in the journal. This is a massive bug


Here to boost this to the top. Playing on XSX. Did almost all of Chapter 1 Season Journey and a few of the other Chapters objectives last night. Turn it on this morning and Season Journey shows I have nothing completed. Everything else is saved as it should be.

Completed an objective to see if it would recognize all that Ive done… nothing. It didnt even register the new objective I just completed. This is a game killer. If it isnt fixed soon, Im out.

1 Like

Almost level 70 and my wifi died I didn’t lose my character but my season journey says I haven’t completed any steps yet (even though I did) and chapter 1 is green ( like it’s completed) and says 0/4 completed, I did another quest to see if it unbugged but it didn’t. Do I have to start from scratch with a new character to get the season journey rewards?

PS - I’m playing on PS4 if that helps

1 Like

It sure does… you’re posting in the wrong forum.

There is a Bug Report forum dedicated to console issues here:

Note to the other players in this post – if you are reporting an issue on the Console version of D3, please use the Console Bug Report forum. There are differences between the PC version and the Console version… hence the need to keep those in separate forums.

Best of luck in your games !

1 Like

Im having the exact same bug on xbox, none of the season journey objectives are being updated when i complete them. I get a pop up but the pop up will say 0/9 objectives completed when I complete one instead of saying 1/9.

1 Like


1 Like

Sorry, I did not clarify. I am playing on PC. I have also tried the scan/repair option, and that’s not working either. I’m going to try to uninstall/reinstall next. Checking for updates also does nothing. I found and deleted the pref txt in documents.

Uninstalling and reinstalling doesn’t work either. I guess I don’t get the season rewards. :frowning:

Pc player here. Same issue, I’m glad I’m not alone. I’ve tried from here: Season Journey and Achievement Bug [Solution]
with no success. Interestingly enough, if I switch to Asia or EU it works fine, but switching back to Americas the problem persists.

Has this bug been fixed yet obviously its game breaking?

Same no rewards for completing chapter 1

There are no rewards for completing Chapter I.


Same here. I was getting credit initially, but now nothing.

I saw that there was a patch other day- I’m still having the same issue after that patch. Has anyone on the Blizzard D3 team seen this bug report?- Like, are you aware of the problem, at least?

1 Like

Ran into an updating issue just now. I’m going for my final conquest—Years of War—and completed a lvl55 grift with full Seeker of the Light set equipped. Nothing. Checked the progress and while my other completed sets are checked, Seeker of the Light remains unchecked. Will restart and try again.

Also having this issue. I’ve killed the bosses on higher than the required level several times, and not getting credit. I’m on PC.

Same here. I’m already paragon 16 and nothing from Chapter 1 and beyond have unlocked. :face_with_monocle: I’m playing in that new solo mode and on the PS5.

same to me
nothing is updated, i ran a few times the chapter and it shows 0/9

YO! Not sure what happened or when- my season journey is working now!! Thanks Blizzard!

1 Like

Has it finally been fixed?