S-19 Group Join Bug


#44

Thank you Matthew. Please share our collective thanks and gratitude with the rest of the folks who worked on fixing this problem.


#45

That would be around 50 minutes ago. Did this go out yet?


#46

Thanks and Happy Thanksgiving.


Thank you to game producer
#47

You rock Matthew. I’m loving the communication!


Thank you to game producer
#48

It is 5 pm New York time and the party bug is still live.


(Matthew Cederquist) #49

Players will have to restart their clients to pick up the fix.

  • This fix does NOT fix the level 0 or missing class in the friends list or communities.
  • This Fix SHOULD fix the Non-Season and Season party bug.

Let us know if you’re still seeing the issue please and thank you in advance


#50

*Eats fix* :wink:


#51

I ended my D3 launcher and game instance and cleared the task manager of all D3 processes.

Launched the client and many friends playing SC and HC season still show as NS SC.

Okay, I do realize all my friends and clan mates must restart as well!

An hour past 5 pm NYT, I have had ppl leave my game and their icon top left is gone.
Before it would just stay there and no matter how many times I clicked the little ‘x’, the gone party member would still show.

I hope this shows all is well after every one has rebooted their system.

Thanks so much Matthew!


#52

Doesnt even begin to fix it on my end Matt, sorry… I tried to join a group party but it said I havent even unlocked Torment 16 when I tried and I clearly have on the selected hero… something not right!


(Matthew Cederquist) #53

Thanks all, we’ll keep looking into it as we go.


Graphics loading issue - possibly related to group join bug?
#54

Has everyone in your party ended their client instance/removing all instance’s of D3 process from Task Manager and restart?

The fix will not work if only one member of a party restart’s!


#55

They all claimed they did but probably didn’t


#56

It definitely didn’t fix it.

Just saw someone in General Chat (around 23:30 GMT / 15:30 PT) on EU asking for a 1-70 boost. Their name showed without a seasonal leaf next to it. Viewed their profile, and confirmed they were actually on a seasonal hero. Whispered them, suggested they switch to a non-seasonal hero, then back to their seasonal hero, and to whisper me once they’d done so. They then showed up with a seasonal leaf, and I gave them a boost.


#57

Did that guy log out and log back in?

The only way to deploy the bug fix is to log out and log back in.


#58

They said they’d just logged in as they hadn’t seen me offering boosts in chat literally 2 minutes before they asked for one.


#59

It’s working fine for me.

Everyone appears proper as HC Season or SC season.

Even leaving games where parties played for an hour or so, didn’t hang the players icon top left and no issues coming back in game thus far!

Time will tell!


#60

I wish I could say the same but people are fools and dont believe me that it happens to me


#61

As a 30 year veteran game developer, I can COMPLETELY sympathize with this tough decision.

I think you made the right call and I am thankful for it.

This bug was absolutely crippling, and if you have squished it that will be WONDERFUL.


#62

They didnt squash it entirely, sadly


#63

Still bugged. Had to get clan members to restart the game to invite them to group just a couple hours ago.