Pixelated lanterns/lights

I am running into this problem on both my 2019 iMac and new 16-inch MacBook Pro. The lanterns and some other lights has these pixelated graphics. Any idea how to fix?
imgur. com/Yqkm3jo (remove space before com)


Hey there Insimbi,

If the problem is only with specific textures or graphics, it may be a file corruption in the game folder. Might be worth a shot reinstalling a clean copy of the game.

Yes, have been seeing this also on a new 2019 iMac, saw some old posts on the old forum site, been going on with retina macs for some time. Happens also on Tyrael’s sword, and awful on some cave entrances. Could not find any “Fix”, was wondering if a clean installation works. Any luck Insimbi ?


I’ve seen this before. You would want to make sure the game’s resolution matches your system’s default resolution. Set resolution scale to 100%. See if that helps!


I’ve tried a clean installation and made sure the resolution was set to 100% scale. Same issue :frowning:


Same here tried all the “Fixes” and no difference. Neither default resolution nor lower resolutions made any difference. Even tried the “open app in low resolution mode” check box from the get info, all the same.

1 Like

A friend of mine has a new iMac & has pixellation at cave entrances etc.

I had this problem since swapping out the original gpu for a rx 580 on my 2010 Mac Pro. Apparently that particular gpu is not fully supported so I live with it or play with the texture settings till it goes away.

I haven’t found a fix on the new iMac.


I really hope Blizzard experts keep is up to date on any efforts to fix this problem. I’d really like to get a new MacBook Pro 16", but I won’t as long as I can’t play Diablo 3 (and maybe 4?) on it Full Screen.

1 Like

Any word about an update to fix the MacBook Pro 16-inch issues?

I have the same problem on my MacBook.
This does happen to several entities such as tree mobs and a character of the story on Act 2.

Model Name: MacBook Pro
Model Identifier: MacBookPro15,1
Processor Name: 6-Core Intel Core i7
Processor Speed: 2,2 GHz
Number of Processors: 1
Total Number of Cores: 6
L2 Cache (per Core): 256 KB
L3 Cache: 9 MB
Hyper-Threading Technology: Enabled
Memory: 16 GB
Boot ROM Version: 1037. (iBridge: 17.16.11081.0.0,0)
Activation Lock Status: Enabled
Mac OS Version: 10.15.1

Tested this internally and was unable to reproduce so far. Could we get other users to post their specs as well so we can see if it’s affecting specific devices?


iMac (Retina 4K, 21.5-inch, 2019)
3 GHz 6-Core Intel Core i5
8 GB 2667 MHz DDR4
L2 Cache (per Core): 256 KB
L3 Cache: 9 MB
Radeon Pro 560X 4 GB

macOS 10.15.2

|Model Name:|Mac Pro|
| Model Identifier:|MacPro5,1|
| Processor Name:|6-Core Intel Xeon|
| Processor Speed:|3.46 GHz|
| Number of Processors:|1|
| Total Number of Cores:|6|
| L2 Cache (per Core):|256 KB|
| L3 Cache:|12 MB|
| Hyper-Threading Technology:|Enabled|
| Memory:|16 GB|
| Boot ROM Version:||
| SMC Version (system):|1.39f11|
| SMC Version (processor tray):|1.39f11|
|System Version:|macOS 10.14.6 (18G2022)|
| Kernel Version:|Darwin 18.7.0|

Chipset Model: Radeon RX 580
Type: GPU
Bus: PCIe
Slot: Slot-1
PCIe Lane Width: x16
VRAM (Total): 8 GB
Vendor: AMD (0x1002)
Device ID: 0x67df
Revision ID: 0x00e7
Metal: Supported, feature set macOS GPUFamily2 v1

So far all users who have reported specs are on Radeon 500 series graphics. Lets try disabling automatic graphics switching to see if it’s using the Intel chips instead of the Radeon ones.

Let us know if this works.

My iMac does not have the integrated chip, so mine is only using the Radeon.
I believe the graphics switching only is on the MacBooks, could be wrong.


Yeah no graphics switching on the old 2010 Pro either.


At this point I’d be looking to see what graphics functions are being used to render those specific assets and find out from Apple whether or not there is a bug in their AMD drivers on the OpenGL side. My bet would be yes, since a) Apple hasn’t updated OpenGL in close to seven years, and b) Apple tends to focus solely on Metal functions, without fully testing OpenGL functions as well.

1 Like

The graphics bug been in the game for years. Lantern and some cave entrance /exit. They even acknowledged it in the old forum. Still no fix after all these years. :frowning:

I have gotten used to them.


Same issue here. Almost gave me a heart attack because I thought that something is wrong with my brand new iMac.

1 Like

Yes, it is pretty sad this is still going on.

1 Like