Malwarebytes - Battle.net update agent went to sleep error

This morning I contacted tech support because of an error that I was getting when I launched the Battle.net app on my PC. [Ticket Number: US97775384 ] In that message I wrote the following text:

As of three days ago I can no longer play any battle.net game on my computer. I have tried all of the following:

  1. Update your drivers and operating system to resolve any compatibility issues. (all of my drivers are up to date.)
  2. Run a security scan to remove any viruses or malware infections. ( I am a computer technician… My computer has the best security money can buy and as such has NO viruses or malware.)
  3. Configure your security software’s exception list to allow Blizzard applications to run. ( I have been playing Diablo 3 Season 30 since it launched with no problems. I verified all firewall settings.)
  4. Create a new administrator account to resolve permissions issues. (I tried this today - Microsoft took over and re-installed a lot of crap I do not want on my computer and reset itself to the setting they want me to use. Still did not work.)
  5. Uninstalling and reinstalling the Battle.net App may resolve rare launcher issues. ( I tried to do this yesterday and the uninstaller would just hang so I forced it’s removal using Revo Uninstaller and re-installed only to get the same issue after re-installing.)

Today at 3:30 I got the following reply from that support ticket from Rainmithwen:

Howdy Roger (OFFENSIVE LANGUAGE)(Howdy as a greeting implies stupidity to me!)
We’re sorry you’re experiencing connection issues in Bnet App. We understand how frustrating this can be, but we’re here to help you resolve these issues. Please follow the steps below, and if the problem persists, consider posting on the Battle.net Game forums or consulting with a local tech expert for further assistance.

  1. Update Graphics Drivers and Windows: Ensure your graphics drivers and Operating System are up-to-date. https://support.blizzard.com/article/000031024
    
  2. Restart Your computer and Router/Modem: Sometimes, a simple restart of your networking equipment can resolve connection issues. https://us.battle.net/support/en/article/31851
    
  3. Disable Background Applications: Close unnecessary background applications, as they might interfere with Bnet App. Check for any resource-intensive programs running in the background and close them before launching the game. https://support.blizzard.com/article/000023848
    
  4. Flush your DNS cache and reset your network configuration. You can do this by opening the Command Prompt (on Windows) or Terminal (on macOS) https://us.battle.net/support/en/article/82450
    
  5. Reinstall the Game: Uninstall Bnet App, restart your computer, and reinstall the game. Corrupted installation files can lead to various issues, and a fresh installation might resolve the problem.
    

If, after following these steps, you are still experiencing issues, we recommend visiting the Bnet App forums. There, you can find a community of players and developers who can provide additional insights or solutions based on their experiences.

If all else fails, I recommend contacting your internet service provider to see if any issues on their end could be causing the problem. They can provide further assistance or troubleshoot any issues with your connection.

Now… I may not be the brightest bulb on the tree, but I think I made it quite clear in MY report that I AM a computer technician, and that I had already followed ALL of the steps listed in my original report. ( I owned a computer repair shop for ten years, and I’ve been playing video games and building computers since the early 90’s.) NOWHERE did I say that was having any kind of issues with my internet connection as would be implied by the support ticket reply. Nor did I say that the problem was with a particular game.

My reply to this topic will include ACTUAL technical support that explains what the problem is I will also include a work around that will let you bypass this until another update from Malwarebytes or Battle.net fixes the issue.

1 Like

Did you actually READ my post ??? I AM A COMPUTER TECHNICIAN !!!

The issue has something to do with a conflict between Malwarebytes and the Battle.net app or the update agent files.

After following ALL of the steps listed on the tech support page that comes up when you click on the error code the issue was not resolved. Despite the half hearted attempt from tech support that marked the ticket as [ “Resolved” ] the issue was NOT resolved.

After spending more than four hours trouble shooting this problem, I have found that if you have Malwarebytes Pro installed on your PC and you play ANY games in the Battle.net app and are receiving this error the following is a valid work-around until an update patch or something fixes it.

  1. Shutdown Malwarebytes.
  2. Start the Battle.net app.
  3. Wait until it is fully loaded and there are no updates still downloading or installing.
  4. Re-start Malwarebytes.

Now if only Malwarebytes or Blizzard will look into this or I find out that it is possibly something unique to my PC hardware or software, this fixes the bug and will at least let you play the games you have without having to do what I did this morning !!!

Sorry - I thought you wanted help.

1 Like

I have been running Malwarebytes from basically the 1st year when it came out. Yes Malwarebytes can do some funny things that I have run across. But I have never ever had Malwarebytes & Battle-net ever have any problem with each other.

I too have been dealing with computers from the early 80’s. One thing you could try is setup another computer and see if happens on that one too.

Same here. No issues when running Malwarebytes with Battle․net App.

My apologies Boubou… I was feeling a bit irritated after spending six hours working on a problem when all I wanted to do was play a game that I OWN on my PC to kill some time… I instead spent the time trying to fix a problem that should not exist.

1 Like

The Malware Bytes issue has been popping up in the MSInfo once exported. If you run into a similar problem in the future, start there to save time.

1 Like

This issue only started after the latest update from Malwarebytes or the Battle.net app a couple of days ago. Or it could be an update from Microsoft that broke it. I’m not sure which. I have had Malwarebytes on this computer since I built it back in 2017 with no problems until just recently.

I was also totally dumbfounded by the response from Blizzard tech support that just assumed that I am a dumb hick and sent me some copy past BS answer that implied that I was having internet issues when I said nothing about internet problems in my support request. They just marked it resolved without even asking me if it was resolved. The response also used what strikes me as offensive language by the person that posted the “resolution” to my problem.

I don’t know if they were trying to be cute, but starting a tech support reply using the word “Howdy” like I’m some kind of hick hillbilly from the south is not a very professional response.

This PC is not Windows 11 compatible, and I do not want a PC that tracks and reports everything I do back to the overlords at Microsoft. Besides I don’t feel like downloading another 30Gb of files to re-install a game that was working fine until some patch or update broke it…

I have a friend that has a Windows 10 computer that he uses in his office. He has software on it that will not work on Windows 11, yet he has to fight with a Windows 11 update that wants to install itself every thirty days because that is the time window that Microsoft allows you to pause the update.

1 Like

I believe this is 100% Battle.net issue;

a few days ago, Battle.net update agent (not even agent.exe, but some temp agent file in the same folder) started to run on 15% CPU 24/7, even restarting itself and running on it’s own after I closed battle.net (YES, your “temporary agent” keeps restarting itself even though ALL instances of battle.net are closed)

I tried deleting cache and all kinds of BS that support suggested, nothing worked… I decided to reinstall battle.net instead, but that sh*tty installer does nothing after clicking continue - not even changing the install directory works

edit: I also have MB premium, never had an issue with it

Getting an auto reply in the first step is normal, as most people don’t bother performing the most basic of troubleshooting before opening a ticket. All you have to do is reopen the ticket. Additionally, your comments about the greeting and who might use it are inappropriate; it is a perfectly normal greeting for people from anywhere.

there’s many more people having the same issue, and looks like it’s not recent BLZBNTBNA00000005 - Battle.net Update Agent went to sleep - #27 by Amalphia-1508 - Desktop App Tech Support - Blizzard Forums

I doubt all of them run malwarebytes

I have driven from one coast of the United States to the other and I have only heard the greeting “Howdy” used on television or in movies !!!

Interesting story. It is used in the south more often than other places, especially in Texas, but it has no relation to someone’s intelligence. Your take on it is uncouth, truly.

Any security or optimization app that shuts down processes it deems unnecessary will cause this issue. It can be a “PC speed booster,” antivirus, or a number of other things. However, the Battle.net client itself doesn’t have a sleep timer that it just suddenly starts using.

First off this is not a story, it is a fact !!! I hauled bombs, missiles, and other munitions for the US government to and from various depots and military basses all over this country back in the 80’s, and as such I have been to almost every state in our republic.

I live in the south so therefore the Blizzard tech that responded to my support ticket was trying to use a greeting that he/her/it deemed acceptable to someone from the south ??? How quaint and totally UN-professional. And yes I have heard Sheldon from the TV show “The Big Bang” use the term when acting like a buffoon in a show once. ( He is supposedly from east Texas if you didn’t know that.)

But on to the topic of the issue with the Battle.net app…

If I launch Bnet without first shutting down Malwarebytes Windows task manager shows one instance of Battle.net.exe running with 6 thread processes. One of those processes is Battle.net Update Agent.exe. There is also an independent process of Battle.net Update Agent.exe running outside of that thread using 30% of my CPU. If I terminate that process it simply restarts. If I expand the Battle.net.exe process tree and close the process there it restarts outside of the process tree and immediately starts consuming 30% of my CPU again. If I close the Bnet app completely and look back at the Windows task manager, both the Battle.net.exe and the Battle.net Update Agent.exe processes are still running and using 30% of my CPU. I can terminate both processes again and they will stay off…

So, in my humble opinion, as a person that has been dealing with computers even before Windows existed, way back when one would have to spend 3 hours writing basic programming code just to play a game of pong, the problem appears to be with the Battle.net app and/or the update agent.

You’re overthinking it. I’m from the north, I know people who use it. You’re fishing for reasons to be upset about the communication that was completely inoffensive. Let it go, let it go~ :musical_note:

Bnet updated and Malware Bytes wasn’t ready for it. It’s really that simple.

1 Like

You know the thing is why do people always point their finger at a game. I have been using some kind of computer for over 40yrs. Been playing video games on those computers for over 40yrs.

In all that time I really have never had a problem running or playing games. If you have to turn off Malwarebytes to get the game to run. Then why would you jump all over Battle-net. Like I said Malwarebytes has had issues in the past after doing some update.

On all games basically the first thing they tell you if you are having a problem with a game. Turn off all antivirus programs to see if that will fix your problem. If turning off Malwarebytes lets you run this game. Then I would be talking to them.

I posted this did you try that to see if it is causing the same problem. You have to have another computer you could seeing if it works. You have a computer repair shop.

Yea, Sure… Like I didn’t do that already… That’s Ok though. The problem magically fixed itself after several people reported the issue. I really don’t care WHO fixed it. I do find it very annoying that I MUST have a really good internet connection and be online to play a game that I paid for. I don’t want to play multi-player games… I WILL NOT run my computer with an internet connection without security software running either… TOO MANY cyber criminals these days you know… The government said so !!!

It might have not been Battle-net. More likely is was Malwarebytes.

Yes you do need some kind of protection, but as tell people all the time. We are the little people and the people doing this really don’t care about the little guy. They want the big boys and not US.

Most of the stuff people get on their computer adware, malware and shareware. Last time I ever had any kind viruses was more than 15yrs ago.

Since I have been using what Microsoft and Malwarebytes gives you. I have never had any problem. All the rest antivirus programs out there are the biggest pieces of crap out.