Graphic card overheating, even in low

Guys I have to wonder, I’m running a 5700XT which is a midrange card, at 4k on high- veryhigh and I’m getting steady easy frames.

No doubt some optimizations can be made but I think some of you need to adjust the fan curve for your GPU.

Also turn on V-Sync, I know some may not like it, but since this game is heavily frame restricted on the old engine, your frames above your monitors refresh hertz isn’t really doing anything for the game.

If you want to reduce the GPU Usage - turn your resolution modifier down, this will force the game to run at a non-native output and reduce the load on the GPU, provided you have V-Sync enabled. If you don’t enable V-Sync when you reduce the resolution scale (%) you’ll just cause your card to work arbitrarily harder.


my ps5 was spewing lava almost

Nope. I may be wrong, but given the time they had to address this long before the beta launch, I doubt it will be fixed anytime “soon”. And this GPU roasting is a major issue. I really don’t want to think about replacing any GPU at today’s prices. There is a reason why the hardware I have lasts so long, I don’t push the limits of hardware unnecessarily and I get years of reliable PC usage in return. My current rig is running on Intel 7th gen architecture and it runs as good as the day I built it. I’ve never had an issue with anything other than an SSD failing.

I’m a huge fan of D2 and I don’t take my decision lightly. I already submitted a refund ticket with support. Peace.


not going to lie i almost loled it would be cute to see an apu get hot from the gpu side though as if that was possible

1 Like

You need to look at your PC more closely.

I have a friend with a 4th gen i7 and a 2 Gigabyte Radeon Sapphire 570 and he can play it just fine with the overlay on.

They just need options to turn the grass waving off or thin it out a bit.

If you want to see what “hair” does to your GPU usage/temps, go run the Furmark benchmark.

Turn the FXAA on, and drop the resolution modifier to 90%, it’ll get rid of that nasty grass shimmer, at least it seriously reduced it for me.

environment detail is the setting you speak of

Yep, and I’m not waiting around for this to be addressed.

1 Like

The grass will still wave around with my setting suggestion, but it stopped the heavily distracting shimmering crap it did when waving. Your results may vary.

Yeah I turned everything down to lowest/disabled everything I could, it was still high GPU usage with grass present. The only thing that significantly helped was reducing the resolution slider to 50% which of course made everything look blurry… Even then it was hovering around 35-40% usage.

1 Like

everything seems fine with my rig. playing at 3440x1440p, everything on max settings. max gpu temp is 62deg c

Try putting ambient occlusion quality to medium

I don’t have any issues with any other game or app. I run vmWare with multiple OSs (different Linux 64bit distros and Win 7 pro 64bit) running simultaneously with other games on the win 10 pro 64bit host. My rigs runs cool and smooth at all times.

D2R, shreds the GPU. I doubt this will be fixed anytime soon.

Last post on this for me, peace.

1 Like

that’s fine but you should probably be over on nvidia’s and/or amd’s forums not blizzard’s to discuss that because the driver teams are in charge of that

To be honest, and I know others may not agree, but I’m actually SHOCKED I haven’t crashed to desktop even once.

Most betas I play in, this happens because the driver team hasn’t caught up yet. If my friend with a PC from 9 years ago can play this with a GPU from 4 years ago, and a 100gig main harddrive, he shouldn’t have had a problem, there’s something else going on.

Played one character to the end of act 2 and only had one crash. 2 server disconnects. I expected WAY worse.

1 Like

The only bad thing I’ve seen with the beta is the lurching cinematics playback. It’s a steady timely lurch that happens maybe every 1/4 second, and it’s like a ‘mini-pause’, then it skips ahead to sync back up… It’s not as noticeable with slow motion in the video, but when there’s fast motion, it’s pretty bad. I hope it’s addressed before the release of the full game because I want to see smooth playback for the act3->act4 Mephy/Diablo cutscene. :smiley:

1 Like

same, same.

I haven’t had a single CTD and only 2 or 3 server disconnects in 6 hours of play. I mean, for a beta, that’s an A from me.

I will admit one thing,

The difference in frame stability even at 60 fps in the open areas is vastly inferior to the “caves” “towers” “crypts” I can tell a significant improvement in frame output in these areas over place like Blood Moor, Dark Forest, Black Marsh etc.

1 Like