Do you old timers remember this? Diablo (1) on Battlenet

Okay. Yeah, I don’t have it on the Battle․net Launcher either. Only on the GOG Launcher.

Extra Info: I don’t think the Battle․net App would find it anyway. It’s installed in the GOG Galaxy games installation folder.

But, now you’ve got me wondering if I ran the Battle․net App and had it Scan for Games and directed it to the GOG/Diablo folder if it would pick up on it. (I probably won’t try it. At least not anytime soon. I’m fine with running from the GOG Launcher).

Okay. I tried it. It didn’t work.

  1. First I copied GOG’s Diablo installation folder into the folder where my Blizzard games are installed.
  2. Then, I ran the Battle․net App and had it scan for games. (It found all the Blizzard games that should be there).
  3. I selected the Missed one? option and selected the Diablo folder I just copied from GOG. But, it did not recognize it.

No problem. I just had  to check it out.  

It won’t find it if you use the original Diablo disk either.

1 Like

Lol, I tried the same thing, with the same result. Bliz must have something tucked away in the Bnet version that the launcher is specifically looking for.

1 Like

https://youtube.com/shorts/P72EtO7PS78?feature=share

Rocking it on the finest of machines

There’s no difference on the graphics themselves, but the GOG one is upscaled to your native resolution (maintaining the 4:3 aspect ratio) while the OG one actually changes your display res. For modern systems, the latter is usually more desirable since it makes tabbing out of the game and such less annoying.

I couldn’t resist. It was only $9.99 USD. So, I purchased it and installed it in the Battle․net App.

I’m curious to see if it runs at high-resolution without resizing my desktop resolution.



Much Later

Well, that was 10 bucks in the trash.

Fair Warning

  1. If you want Diablo  to play on your current computer, buy GOG’s copy.
  2. Blizzard’s copy will not run on Battle․net.
  3. Blizzard’s copy only runs what GOG calls Diablo Classic. (640x480).
  4. Blizzard’s copy does not have Hellfire  on the App. (You’ll have to run it from the executable in the Hellfire  folder).
  5. Blizzard’s copy does not have the high-resolution option.
  6. GOG and Blizzard are charging the same price for their copies.

Note: GOG’s Classic can no longer run Multiplayer on Battle․net (at the moment). GOG’s high-resolution option can run on Lan connection only. (Or Direct Connect and TCP/IP).

Single Player will run on any of them.

TL:DR — If you want Diablo + Hellfire  buy it from GOG.

5 Likes

Microsoft, fix Blizzard please.

1 Like

I did not think the original disk would have that much at all. Blank CDs back then were like 750mb I think? Although now that I think about it, if the original installation was in the low 100’s it makes sense that so much would run off the CD, videos would run off them at the time as far as I remember.

This original disk talk just makes me think how it was a mistake to not keep mine. I kept all the games from back then for a while afterwards but sadly didn’t think it was necessary to keep them later on. At least I still have my original Brood War.

You can still salvage that purchase using devilutionx (I use it even with the GOG version, it’s better). Widescreen support and lets you press alt to highlight items on the ground.

1 Like

The original disk has a lot of other .DLL files on it. Plus the manual, Smackplayer, install, video file extras, DirectX7, etc. The resource file (MPQ) for the game itself is 505,373kB. My disk is a Battle Chest version because my first one developed a crack in it.

A CD is 700MB but you usually can only burn 650 MB on it because of reserved space.

1 Like

Back in the day, I could never get Diablo 1 to run on my P90. I’d be lucky to get to watch the intro cutscene but the game would always crash when trying to load the menu screen. Guess my computer wasn’t good enough.

I’m afraid if I get this, I’ll have trouble running this on a computer that’s now too good :rofl:

I still have the original Diablo CD somewhere.

Was running it on an AMD x86, Pentium wannabe. 14" monitor!

Still have the original CD. Absolutely love this game. I ripped the music from it and burned the MP3s to disc so I could listen to it anywhere.

Favorite memory… Remember the old Boba Fett Trainer?

I started a public game wtih Boba Fett set to full god mode. I ran down to Diablo killing as few as possible so I the game would remain open to as low level as possible. I cast a town portal and waited… Some poor dude joined my game as a level one and chatted “Cool! Can I take your portal?” I said “Come on down”.

Of course he gets whacked but was cool about it. “Oh sht! Diablo!”.

He laughed about it and said “Good one, man”.

1 Like

Thank you for sacrificing Hamilton to find this information out. Aaron Burr would be proud.

:smiley:

1 Like

Yeah, it seems that GoG’s D1 version is much more stable and user friendly. I’ve had GoG’s D1 for a while but I’ve never played multiplayer with it. So I tested it out.

It worked for me. Initially, I got the port 6112 error that others have reported, however, all I needed to do was forward the indicated network ports and GoG’s Battlenet multiplayer ran perfectly. Made a character, made an account, and once in, made a game. Granted, there’s no one on D1’s Bnet atm so I couldn’t test joining a game.

So yeah, I agree, buy from GoG for the time being. It connects to the same Battlenet as Bliz’s version so it’s not like the two are split up.

The very existence of the enhanced version in GoG’s package makes it worth more than Bliz’s (since they are the same price).

2 Likes

This forum should get a D1 clan going :rofl:

1 Like

Kick that :poop: lol done now

Back in SC2’s heyday, the forum regulars formed a clan called SFP - SC2 Forum Posters.

There were ~100 members at its peak. lol.

Yeah. I forgot I have a different modem/router combo now. I had to log in to my modem gateway and add the Custom Port Forwarding Service again. It didn’t help.


Actually, it looks like it is trying to let me in. But, I was getting the same thing before I added the Custom Port Forwarding Service.

I’m not getting the Port 6112 error. After selecting my Battle․net Character I get a log in window with blank buttons and empty log in fields.

The problem is, I don’t remember what information to type in the fields. It seems like it required retyping the name of the Character. But, I can’t remember what to use in the second field.

Huh, that’s a strange one. Here’s the UI with the text on it:

This is the old Bnet so you’d need to remember the name/password of your char(s) way back then. There was no chance I was going to remember, so I just made a new one.

Did you put the full range in? 6112-6119?